[ESS] ess-r-set-evaluation-env problems

Boylan, Ross Ro@@@Boy|@n @end|ng |rom uc@|@edu
Sat Jul 23 06:32:13 CEST 2016

I tried debugging this.  Under the debugger it seemed to run successfully!  Itt showed a list of  package names to select from in the prompt area (which it didn't do before), and, I think, let me select one of them.

During the package selection logic, It searched unsuccessfully for a DESCRIPTION file in the working directory and its parents (the package had been loaded from a library, and the source code was one level below the working directory).

I did notice the wrong type argument message several times while I was tracing through the functions.

I also noticed some uses of file-exists-p; I have a hazy recollection this function accounted for some similar errors because it wasn't defined, or was defined differently, in earlier versions of emacs.  But 24.4 is pretty current.

From: Boylan, Ross
Sent: Friday, July 22, 2016 7:20 PM
To: ess-help using r-project.orgess)Top > Developing with ESS > ESS developer  ronment, when I do C-c-C-t C-s or the equivalent command (see subject) the echo area shows "wrong type argument: stringp, nil".

After toggling on the emacs debugger:
Debugger entered--Lisp error: (wrong-type-argument stringp nil)
  call-interactively(ess-r-set-evaluation-env record nil)
  command-execute(ess-r-set-evaluation-env record)
  execute-extended-command(nil "ess-r-set-evaluation-env")
  call-interactively(execute-extended-command nil nil)

Also, the info documentation seems internally inconsistent; the news indicates using the command above is the way to go, but (ess)Top > Developing with ESS > ESS developer, section 10.3, seems to have the old commands, which do not work--or at least C-c C-t C-a gets me the same error.

Ross Boylan

More information about the ESS-help mailing list