[ESS] ess-r-set-evaluation-env problems

Vitalie Spinu @p|nuv|t @end|ng |rom gm@||@com
Sat Jul 23 23:02:41 CEST 2016

This functionality was completely rewritten. You now rarely should need that
function. What do you want to achieve?

The manual docs were indeed obsolete. Thanks! I have just fixed that.


>> On Sat, Jul 23 2016 04:32, Boylan, Ross wrote:

> I tried debugging this.  Under the debugger it seemed to run successfully!  Itt showed a list of  package names to select from in the prompt area (which it didn't do before), and, I think, let me select one of them.

> During the package selection logic, It searched unsuccessfully for a DESCRIPTION file in the working directory and its parents (the package had been loaded from a library, and the source code was one level below the working directory).

> I did notice the wrong type argument message several times while I was tracing through the functions.

> I also noticed some uses of file-exists-p; I have a hazy recollection this function accounted for some similar errors because it wasn't defined, or was defined differently, in earlier versions of emacs.  But 24.4 is pretty current.

> Ross
> ________________________________________
> From: Boylan, Ross
> Sent: Friday, July 22, 2016 7:20 PM
> To: ess-help using r-project.orgess)Top > Developing with ESS > ESS developer  ronment, when I do C-c-C-t C-s or the equivalent command (see subject) the echo area shows "wrong type argument: stringp, nil".

> After toggling on the emacs debugger:
> Debugger entered--Lisp error: (wrong-type-argument stringp nil)
>   directory-file-name(nil)
>   ess-r-package--find-package-path()
>   ess-r-package--local-package-info()
>   ess-r-package-get-info()
>   ess-r--select-package-name()
>   ess-r-set-evaluation-env(nil)
>   call-interactively(ess-r-set-evaluation-env record nil)
>   command-execute(ess-r-set-evaluation-env record)
>   execute-extended-command(nil "ess-r-set-evaluation-env")
>   call-interactively(execute-extended-command nil nil)
>   command-execute(execute-extended-command)

> Also, the info documentation seems internally inconsistent; the news indicates
> using the command above is the way to go, but (ess)Top > Developing with ESS >
> ESS developer, section 10.3, seems to have the old commands, which do not
> work--or at least C-c C-t C-a gets me the same error.

> Ross Boylan

> ______________________________________________
> ESS-help using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list