[ESS] ess-remote and help buffers

Erik Iverson eriki at ccbr.umn.edu
Wed Aug 18 04:53:38 CEST 2010

On 08/17/2010 06:05 PM, Leo Alekseyev wrote:
> Hello all,
> I use ESS-remote quite a bit (works very well with x forwarding on a
> fast network).  The one thing that doesn't work for me is ESS help
> buffers.  If I do ?foo, I will get help text printed directly to the
> command line, with some escape characters near the prompt.  If I do
> C-c C-v (name of object), I get an error: could not find function
> ".help.ESS".  If I set .help.ESS<- help (like in local sessions) and
> do C-c C-v (object), R hangs and I have to kill emacs.  I'd appreciate
> any hints on how to get help (when in ess-remote) working the same way
> it does in local sessions.

I seem to have just had success with the following recipe:

I don't actually use ess-remote for this, but rather the "tramp"
method for remote R sessions.  That is, I visit a remote file with
/user at machine:/path/to/file.R, and then with point in the remote
.R buffer, I run M-x R to get a remote R session.

Then immediately run:

 > options(pager = "cat")


 > ?lm

seems to work for me.

I just tried with ess-remote, and the above seems to work
conditional on the

 > .help.ESS <- help

assignment being made.

Hope this helps! I use GNU Emacs 23.2 with ESS 5.11.

--Erik Iverson

More information about the ESS-help mailing list