[ESS] Process R hangup

Rodney Sparapani rsparapa at mcw.edu
Fri Oct 3 15:34:13 CEST 2008

karl FORNER wrote:
> Hello,
> We're experiencing a strange problem here using xemacs + ESS on an Altix with
> itaniums.
> When we run via ESS (eval line or eval region) a R command that is not
> instaneous (say >= 30 seconds), the iESS window freezes with the following error
> message : 
>  "Process R hangup at Fri Oct  3 14:12:19 2008"
> I have no idea from where it comes "I tried so grep for the word "hangup"in the
> whole src tree of xemacs, R and ESS without any success.
> The problem is reproducible with the following commands :
> library(affyPLM);
> load("data.affyBatch.rda")
> data.affyBatch.plm <- fitPLM(data.affyBatch, model=PM~-1+probes+samples);
> it's the last command the produces the error after a few tens of seconds. 
> The very same commands on another linux box run just fine.
> Here're the details of the computer :
> Altix with 1.6 Ghz Itanium 2 cpus, running SUSE LINUX Enterprise Server 9 (ia64)
> I tried various xemacs 21.4.x versions, including the last one.
> And two versions of ESS.
> Someone has any clue of what could cause this problem, or whom I should ask for
> help ? 
> Thanks
> Karl

Hi Karl:

It's a bug, but where is it?  Do you have the latest version of the SUMO
packages installed?  I don't recognize this particular problem, but I 
have seen other weirdness that can be resolved by updating those.  And I
don't get one other thing.  I installed all R packages, but affyPLM is
not here.  Is there some non-obvious dependency for this package?
Without it, I can't try your example.


More information about the ESS-help mailing list