command line arguments to R

Stephen Eglen stephen at
Thu Aug 5 12:53:41 CEST 2004

 > >  > Ok, something is not working.  Do you see "R-1.9.1-my" in the "ESS ->
 > >  > Start Process -> Other" menu?  (Check that R-1.9.1-my is executable
 > >  > from the command line on its own, i.e. executable bit set).
 > >  > 
 > >  > If you can't do M-x R-1.9.1-my from the command line, it won't work
 > >  > with the -f switch from the command line.  I just tried the following,
 > >  > which worked:
 > [...]
 > I just got it to work too.  Key was getting  "R-1.9.1" in the name of the 
 > shell script.

yep, that's because of the following variable [note we have made it a
little future-proof for when R 2.x comes out!]


ess-r-versions's value is ("R-1" "R-2")

*List of partial strings for versions of R to access within ESS.
Each string specifies the start of a filename.  If a filename
beginning with one of these strings is found on `exec-path', a M-x
command for that version of R is made available.  For example, if the
file "R-1.8.1" is found and this variable includes the string
"R-1", a function called `M-x R-1.8.1' will be available to run that
version of R.
If duplicate versions of the same program are found (which happens if
the same path is listed on `exec-path' more than once), they are
ignored by calling `ess-uniq-list'.

More information about the ESS-help mailing list