command line arguments to R

Pierre Kleiber pkleiber at
Wed Aug 4 21:01:58 CEST 2004

Stephen Eglen wrote:
>  > Ok, something is not working.  Do you see "R-1.9.1-my" in the "ESS ->
>  > Start Process -> Other" menu?  (Check that R-1.9.1-my is executable
>  > from the command line on its own, i.e. executable bit set).
>  > 
>  > If you can't do M-x R-1.9.1-my from the command line, it won't work
>  > with the -f switch from the command line.  I just tried the following,
>  > which worked:


I just got it to work too.  Key was getting  "R-1.9.1" in the name of the 
shell script.

> p.s. all of this seems somewhat like a hack.  I'm wondering whether we
> should have an extra var for people to pass arguments they use often?

Yes... I'd vote for that.
  Thanks for you help.   Cheers, Pierre

> Stephen
> ______________________________________________
> ESS-help at mailing list

Pierre Kleiber, Ph.D       Email: pkleiber at
Fishery Biologist                     Tel: 808 983-5399/737-7544
NOAA FISHERIES - Honolulu Laboratory         Fax: 808 983-2902
2570 Dole St., Honolulu, HI 96822-2396
  "God could have told Moses about galaxies and mitochondria and
   all.  But behold... It was good enough for government work."

More information about the ESS-help mailing list