[ESS] [OT] Enabled a hook and no longer find which

Dirk Eddelbuettel edd @end|ng |rom deb|@n@org
Sat Jul 31 04:39:00 CEST 2021

On 30 July 2021 at 21:32, Andreas Leha via ESS-help wrote:
| wild guess:  file/dir local variable?

I considered that too esp as I see it only in some repos. But no repo-local
file I can see or tell (and I know repo layout / files well enough).

On 30 July 2021 at 17:27, Tyler Smith via ESS-help wrote:
| Maybe check the values of before-save-hook and after-save-hook while
| visiting one of the files this problem applies to? You might find a function
| name you can grep for in your config.  

Yes hooks had come to mind and I tried 'C-h v' and 'C-h f' for a few
variables and functions. Still no smoking gun.

| If it's only in certain directories, check if there is a `.dir-locals.el`
| file in that directory (or one of its parents).

'locate' shows that I have a few .dir-locals.el on my machine but they all
come from different upstreams.

Good suggestions, though.  Thank you both.  Still poking, mostly in the dark.


https://dirk.eddelbuettel.com | @eddelbuettel | edd using debian.org

More information about the ESS-help mailing list