[ESS] [OT] Enabled a hook and no longer find which

Stephen Berman @tephen@berm@n @end|ng |rom gmx@net
Mon Aug 2 23:56:57 CEST 2021

On Fri, 30 Jul 2021 12:56:11 -0500 Dirk Eddelbuettel via ESS-help <ess-help using r-project.org> wrote:

> tl;dr: I enabled an action 'on save' and I no longer find where :-/
> Longer story: I settled upon GNU global and ggtags at some point for a
> (mostly multilingual) system of tags in R and C++ (and some more). So a few
> of source directories have these (ugly names) files GPATH, GTAGS, GRTAGS.
> And at one point I became too clever by half and somehow enabled updating of
> these files for at least some repos. But I no longer remember _how_ I did
> that and can, for the life of me, find any trace in my .emacs (and, older
> story, .elisp/*el) file(s).

On Fri, 30 Jul 2021 21:39:00 -0500 Dirk Eddelbuettel via ESS-help <ess-help using r-project.org> wrote:

> On 30 July 2021 at 17:27, Tyler Smith via ESS-help wrote:
> | Maybe check the values of before-save-hook and after-save-hook while
> | visiting one of the files this problem applies to? You might find a function
> | name you can grep for in your config.
> Yes hooks had come to mind and I tried 'C-h v' and 'C-h f' for a few
> variables and functions. Still no smoking gun.

Did you also try the more direct alternative of grepping simply for
"GPATH", "GTAGS", "GRTAGS"?  Presumably whatever function updates these
files has to refer to them, either directly by name or indirectly by a
variable or function that in turn refers to them directly or indirectly.
So it should be possible to find the update function by inspecting all
code that uses these file names (directly or indirectly).

Steve Berman

More information about the ESS-help mailing list