[ESS] connection to Oracle does not work in ESS

Bond, Stephen Stephen@Bond @end|ng |rom c|bc@com
Thu Dec 14 16:42:48 CET 2017

ESS or emacs stores sth between sessions! I tried quitting the R session and connecting from a new session in the same emacs window and it did not work.
Today I closed the whole emacs window and reopened the same R code and it worked.


-----Original Message-----
From: Vitalie Spinu [mailto:spinuvit using gmail.com] 
Sent: Wednesday, December 13, 2017 5:34 PM
To: Bond, Stephen
Cc: 'ess-help using r-project.org'
Subject: Re: [ESS] connection to Oracle does not work in ESS

Hi Stephen,

I doubt it's problem with ESS. Running R from emacs shell and with ESS should be equivalent. Make sure that it's indeed the same R instance and RODBC what are called in your experiments. Do you have a custom inferior-ess-r-program-name setup?

Do you issue Rterm or R in the emacs shell?


>> On Wed, Dec 13 2017 22:23, Bond, Stephen wrote:

> Further info:

> When I use Rterm in a cmd shell the connection works.
> When I use Rterm in a shell within Emacs the connection works.
> Something must be going wrong in the way ESS does things.

> Stephen

> From: Bond, Stephen
> Sent: Wednesday, December 13, 2017 12:53 PM
> To: 'ess-help using r-project.org'
> Subject: connection to Oracle does not work in ESS

> On 64-bit win7:

> I have a DSN which tests successfully in control panel. I can connect from RGui with:
> con=odbcConnect("DSNname",uid="myuid",pwd="mypass")

> it does not work in ESS:

> R version 3.4.2 (2017-09-28) -- "Short Summer"
> Copyright (C) 2017 The R Foundation for Statistical Computing
> Platform: x86_64-w64-mingw32/x64 (64-bit)

>> > options(chmhelp=FALSE, help_type="text")
>> options(STERM='iESS', str.dendrogram.last="'", 
>> editor='emacsclient.exe', show.error.locations=TRUE)
>> library(RODBC)
>> con=odbcConnect("DSNname",uid="myuid",pwd="mypass")

> Warning messages:
> 1: In RODBC::odbcDriverConnect() :
>   [RODBC] ERROR: state 08004, code 12154, message 
> [Oracle][ODBC][Ora]ORA-12154: TNS:could not resolve the connect 
> identifier specified
> 2: In RODBC::odbcDriverConnect() :
>   ODBC connection failed

> I have all the paths setup and the driver is installed correctly. Tnsping finds the db.

> Let me know if anybody can help.

> Stephen

> 	[[alternative HTML version deleted]]

> ______________________________________________
> ESS-help using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list