[ESS] "?" not working with Julia?

Ramon Diaz-Uriarte rd|@z02 @end|ng |rom gm@||@com
Sun Jan 10 13:22:11 CET 2016

Problem solved, though I do not really understand why. I was seeing the
problem in a machine where I had not installed any Julia packages; things
got solved as soon as I installed a Julia package with Pkg.add (Gadfly
here, but I guess anything else should do).

I do not know if this is a Julia issue or an ESS issue or something else,
but maybe the documentation at https://github.com/emacs-ess/ESS/wiki/Julia
could say something like "You might want to have installed at least one
Julia package via Pkg.add to ensure that the help works".

Details and reproducing the problem:

This can be easily reproduced in a machine with installed Julia packages as

  a) Exit Julia and Emacs

  b) Move your .julia somewhere (e.g., "mv .julia juliadot")

  c) Start emacs, load ESS, start Julia

  d) Try to get help for something. It fails.

  e) Fix things back:
     e.1) Exit Julia and Emacs

     e.2) Restore your .julia (e.g "rm -r -f .julia" and "mv juliadot

     e.3) Restart emacs, load ESS, start Julia. Getting help works again.

In a machine without any packages I get:

julia> whos()
                          Base  24224 KB     Module
                          Core   2850 KB     Module
                           ESS    851 bytes  Module
                          Main  26845 KB     Module
                           ans      0 bytes  Void


julia> Pkg.status()
INFO: Initializing package repository /home/ramon/.julia/v0.4
INFO: Cloning METADATA from git://github.com/JuliaLang/METADATA.jl
No packages installed

The entry for ESS in particular seemed suspicious: whos() in a machine with
installed packages shows about 14 KB for ESS and ESS/lisp/ess-julia.el
makes Julia load the ESS module from ESS/etc/ess-julia.el (module ESS) when
we M-x Julia.



On Sun, 10-01-2016, at 12:19, Ramon Diaz-Uriarte <rdiaz02 using gmail.com> wrote:
> Hi Stephen,
> On Sat, 09-01-2016, at 22:09, Stephen Eglen <sje30 using cam.ac.uk> wrote:
>>> Thanks. If I may ask, if on Julia you type, say
>>> help("fft")
>>> do you get an error? That is what I get with the generic Linux Binary for
>>> Julia 0.4.2 (downloaded right now from the julia page) and v. 0.4.2-3 from
>>> Debian sid. However, I do not get an error if I use Julia 0.3.12.
>> hi Ramon,
>> I see the same within Julia started from the terminal; I think I had to
>> update the ESS code a while ago to use the new (0.4) interface for help.
> But this is what I do not understand, because I have freshly installed ESS
> from git and I am loading nothing but ESS. This is what I do:
> - Remove all of the former ESS directory.
> - Do as instructed in https://github.com/emacs-ess/ESS/wiki/Julia
>   - git clone git://github.com/emacs-ess/ESS.git
>   - git pull [not needed, but anyway]
>   - make all
> - Start Emacs as:  "emacs -Q"
> - Execute (load "path/to/ESS/git/lisp/ess-site")
>   [I do not need to specify the path tp inferior-julia-program-name, as it
>   is in /usr/bin, but specifying it makes no difference ]
> - M-x julia
> - Try to get the help for something, and it fails with the "ERROR:
>   UndefVarError: help not defined"
> The following is the complete content of the *Messages* buffer contents
> after the above (plus asking for ess and emacs versions):
> ######################################
> For information about GNU Emacs and the GNU system, type C-h C-a.
> Loading /home/ramon/Sources/ESS/lisp/ess-site...done
> t
> Type C-h m for help on ESS version 15.09-2 patched
> ERROR: UndefVarError: help not defined
> GNU Emacs 24.5.1 (x86_64-pc-linux-gnu, GTK+ Version 3.18.6) of 2015-12-14 on binet, modified by Debian
> ess-version: 15.09-2 patched [git: 837454b76475a4eb3256e288fe4149a927faefa9] (loaded from /home/ramon/Sources/ESS/)
> #####################
> This process does work on another computer, so something is different and
> broken in one machine, but for the life of me I just can't understand what
> it is. I compared ---with diff--- the ESS directories in both machines and
> the *.el files are identical; also identical are the versions of Emacs and
> Julia. I removed all of the *.elc under ESS/lisp to force usage of the
> source .el files, and it still fails.
> Best,
> R.
>> Stephen

Ramon Diaz-Uriarte
Department of Biochemistry, Lab B-25
Facultad de Medicina
Universidad Autónoma de Madrid 
Arzobispo Morcillo, 4
28029 Madrid

Phone: +34-91-497-2412

Email: rdiaz02 using gmail.com
       ramon.diaz using iib.uam.es


More information about the ESS-help mailing list