[ESS] emacs24 crash when start R

Ista Zahn |@t@z@hn @end|ng |rom gm@||@com
Mon Aug 17 03:10:39 CEST 2015

On Sun, Aug 16, 2015 at 6:52 PM, Riccardo Romoli <ric.romoli using gmail.com> wrote:
> Hi, I get an annoing problem running R from emacs. When I try to run R (M-x
> R) emacs crash. I run emacs 24.4.1, ESS 14.09, R 3.2.1. under Debian jessie.
> I tried to run R from shell and it works.
> Do you have any suggestion?

Just the usual:

1) Update emacs and ess to the latest released versions.
2) Start emacs with 'emacs -Q', load ESS and see if the problem persists
2a) if 'emacs -Q' works, comment out half of your emacs initialization
file and see if it works. If it does uncomment half of the previously
commented section, if it doesn't work comment out half of the
uncommented section. Repeat until you identify the section causing the
3) Start emacs with 'emacs -Q', turn on debugging with 'M-x
toggle-debug-on-error' start, R, and see if the backtrace gives you
any clues.

Hope this helps,

> All the best, R
> ______________________________________________
> ESS-help using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list