[ESS] ess-eval-line-and-step

Kasper Daniel Hansen kasperdanielhansen at gmail.com
Wed Sep 17 03:20:31 CEST 2014

Thanks James, setting
  (setq inferior-ess-same-window nil)
solved the problem.

Vitalie, I agree that it is probably some user setting.  But what I did in
the last couple of days was update to the latest Emacs 24.4-pretest from
24.3 (after which I _think_ it worked, but I could be wrong) and then
update from 14.05 to 14.09.  One of those two changes gave me the new
behaviour, I think it was the ESS update but I could be wrong.  I have not
made any changes to anything.  I am installing ESS using el-get, so perhaps
that does something.  I was reporting it exactly because I know I did not
change any configuration.

Also Vitalie, out of curiosity, how do you get GNU Emacs  I
believe I am running the latest pretest, and I get  Is that
because you are checking out from a source code repository?  I am testing
their pre-release (which I thought would be new and a bit tested), but I am
not an expert on the Emacs release schedule and the associated version



On Tue, Sep 16, 2014 at 9:09 PM, Vitalie Spinu <spinuvit at gmail.com> wrote:

> No changes have been made with that regard. So it's either a bug or some
> personal add-on or configuration of yours. Given that nobody sees this
> severe problem, it's probably the latter.
> Would be nice if you could edebug `ess-eval-line-and-step` and find the
> location of the code where the switch happens. Then we can be more
> helpful.
> Relatedly, I have been noticing some annoying behavior of pop-to-buffer
> function in GNU Emacs but it's not ESS specific as far as I
> can tell.
>   Vitalie
>  >>> Kasper Daniel Hansen on Tue, 16 Sep 2014 11:21:57 -0400 wrote:
>  > I just updated my emacs and ess on OS X.  Now running ess 14.09 and
> emacs
>  >
>  > I now get a completely different behaviour of ess-eval-line-and-step.
>  > Previously, it would send the current line to the inferior R process and
>  > then more down one line.  The R process would pop up in a new window
> next
>  > to my current window, so I would be able to see both the R script and
> the R
>  > session.
>  > Now, the window with the R script switches from displaying the R buffer
> to
>  > displaying the R process.  Besides being really irritating, this
> basically
>  > destroys the function because I cannot step two lines without switching
>  > buffers in between.
>  > Presumably, there is some configuration setting that I need to set.
>  > Best,
>  > Kasper
>  >      [[alternative HTML version deleted]]
>  > ______________________________________________
>  > ESS-help at r-project.org mailing list
>  > https://stat.ethz.ch/mailman/listinfo/ess-help

	[[alternative HTML version deleted]]

More information about the ESS-help mailing list