[ESS] R in Cygwin Emacs

Sebastien Vauban sva-news at mygooglest.com
Wed Sep 3 17:20:32 CEST 2014

"Richard M. Heiberger" wrote:
> On Wed, Sep 3, 2014 at 5:16 AM, Sebastien Vauban wrote:
>> I try to use Cygwin Emacs, and have problems launching R inside it.
>> All the Google searches suggest to add:
>> --8<---------------cut here---------------start------------->8---
>>     (setq ess-program-files "c:/PROGRA~2")
>>     (setq ess-program-files-64 "c:/PROGRA~1")
>> --8<---------------cut here---------------end--------------->8---
>> That's what I did, as you can see in the beginning of
>> http://screencast.com/t/8k7NfKYHFb; though, I still get the warnings,
>> and R is not launched.
>> Any experience on this?
> Your screencast came up empty.

It's working for me (tested once again). Weird!?

> I have been using R inside Gnu emacs for about 20 years.  I also run
> cygwin shell inside Gnu emacs.
> I have never tried cygwin emacs.

I don't have problems in "NT" Emacs (the Windows binaries), only with
Cygwin Emacs -- which is the target I'm supposed to follow.

> In Gnu emacs both of the emacs variables you mention are already set
> in ess-custom.el.  You don't have to do anything.

If I don't set them in the above way, when running `M-x R', I'm blocked
with the message:

--8<---------------cut here---------------start------------->8---
Warning (emacs): None of 'w32-short-file-name, 'win32-short-file-name,
or 'mswindows-short-file-name are defined!
You will have to manually set   ess-program-files (in ess-custom.el) to
the correct "8.3"-style directory name.
--8<---------------cut here---------------end--------------->8---

Best regards,

Sebastien Vauban

More information about the ESS-help mailing list