[ESS] Anyone get "Text is read-only" issues lately?

Frede Aakmann Tøgersen frtog at vestas.com
Fri Nov 14 19:53:25 CET 2014

Hi All

Sorry for stepping in that late. I recognize your frustration, Grant (been there several times).

I followed this thread and were thinking about giving my advice but I didn't have the time.

When something is not working in emacs across different modes it is probably due to something in one's initialization files (my advice).

One way to examine that is to start emacs with the command line argument -q meaning that emacs will  not use any files like your .emacs  in your home directory or other system-wide files. In the case of debugging ESS you would then only load that package from within emacs for further debugging. I guess that is what Vitalie is referring to. In your case  I guess you discovered that the ESS would have worked okay leading to further debugging as you did. 

I'm quite sure you made an effort to solve your problem. Luckily you shared the solution to the list. This is important because other people may benefit from your experiences. 

Vitalie is doing an immensely great job for the ESS community. But he is probably lacking time for programming and for helping people even though he is trying to do so. 

Pardon my English. 

Yours sincerely / Med venlig hilsen

Frede Aakmann Tøgersen
Specialist, M.Sc., Ph.D.
Plant Performance & Modeling

Technology & Service Solutions
T +45 9730 5135
M +45 2547 6050
frtog at vestas.com

Company reg. name: Vestas Wind Systems A/S
This e-mail is subject to our e-mail disclaimer statement.
Please refer to www.vestas.com/legal/notice
If you have received this e-mail in error please contact the sender. 

> -----Original Message-----
> From: ess-help-bounces at r-project.org [mailto:ess-help-bounces at r-
> project.org] On Behalf Of Grant Rettke
> Sent: 14. november 2014 18:07
> To: Vitalie Spinu
> Cc: ess-help at stat.math.ethz.ch
> Subject: Re: [ESS] Anyone get "Text is read-only" issues lately?
> Good morning VItalie,
> My communication was imprecise, and I am sorry for that.
> It looks to you like I said that I tested *without* my ESS config,
> asked for help, then told you and everyone else that I was lying by
> actually testing *with* my custom config, thus wasting your time and
> being labeled as a liar, and I am sorry for that because that is also
> *not* the case. Here is what happened.
> My configuration is split up into different sections. There is a
> section for ESS because it is a full blown mode. There is also a
> section for comint because it is a full blown mode. I don't see these
> two modes as having anything to do with each other beyond the former
> being derived from the latter.
> When I did the aforementioned testing, I did indeed remove all of my
> ESS configuration and I left my comint configuration and made a single
> call to require 'ess-site. That is how I was able to narrow down the
> problem. It had nothing to do with my ESS configuration.
> The fact that I replied here with the issue was simply to resolve the
> topic, and again say "Thanks" for helping me out with it. So, again,
> my apologies for the confusion here, as I greatly respect and value
> your and everyone else's time, and do understand that every email sent
> to the list does have a cost and that you and other generous folks are
> the ones paying that cost!
> The nature of the change itself? I have no clue what is the issue.
> I've had that setting in place for a long, long time and it has worked
> as I had expected it. What changed in the past month or two making it
> not produce the desired behavior? Unknown. What I posted on was the
> fix, and maybe it should never have produced hte desired behavior in
> the first place. That is why it was so surprising though, because
> neither my ESS nor my comint configuration had changed in two months,
> thus, the surprise!
> Kind regards,
> gcr
> On Thu, Nov 13, 2014 at 12:25 PM, Vitalie Spinu <spinuvit at gmail.com> wrote:
> >
> >
> >
> > [...]
> >
> >  > Suspect this has to do with me using a custom prompt expression.
> >
> > Didn't you say that you removed all your ESS/R configuration? You should
> > not customize R prompt and customize ESS prompts only if you know what
> > you are doing.
> >
> >
> >   Vitalie
> --
> Grant Rettke
> gcr at wisdomandwonder.com | http://www.wisdomandwonder.com/
> “Wisdom begins in wonder.” --Socrates
> ((λ (x) (x x)) (λ (x) (x x)))
> “Life has become immeasurably better since I have been forced to stop
> taking it seriously.” --Thompson
> ______________________________________________
> ESS-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list