[ESS] Using ESS with S-plus 8.1

Tayler Lawrence Jones t.jonesd289 at gmail.com
Wed Nov 5 23:28:48 CET 2014

Hello all,

I'm working on a project that is in S+ 8.1, and I am using Windows 7 with
the latest packaged ESS from Vincent. The folder to splus.exe and sqpe.exe
is in PATH.

Is there anyway to get that version of S+ running in ESS?
R works no problem. S+, however, is nothing but trouble.

M-x S tells me to run from icon, then use M-x S-existing.
Doing so with M-x S-existing causes emacs to hang up and crash.
M-x Sqpe lets me select a starting directory, but then gives the error
'spawning child process: invalid argument' and nothing happens.

I have tried adding these lines of code to my .emacs file (based on some
outdated mailing list threads), but the result is the same:

(require 'ess-site)(setq-default inferior-S-program-name "C://Program
Files (x86)//TIBCO//splus81//cmd//SPLUS.exe")(setq-default
inferior-Sqpe-program-name "C://Program Files

Note: I have tried with single slashes as well.

I get the same result if I do S+6, Sqpe+6, etc.

Does anyone know if this is even possible? I am an emacs fiend, so it
drives me crazy that S+ won't work in ESS for me.

Thanks for any help!

PS - I am in the process of porting the code to R, but it needs to be
utilized in the interim. So, unfortunately, just using R is not an option
right now.

	[[alternative HTML version deleted]]

More information about the ESS-help mailing list