[ESS] ESS tracebug watch always empty

Ross Boylan ross at biostat.ucsf.edu
Thu Jan 30 19:59:42 CET 2014

In brief, I am unable to add expressions to the watch window.

While tracing through a function after a breakpoint from tracebug I did 
C-c C-T w, which caused a watch window to pop up.  I think I was in the 
*R* window when I gave the command, and since I had typed on the command 
line in that window the message about using M-N etc to step was not visible.

The watch window opened with instruction to use, for example, a to 
append to expressions to watch.  I typed a and was prompted for an 
expression.  I entered the name of a field in the reference class I was 
debugging.  After I hit enter the watch window was unchanged.  I tried 
with some other variables and, I think, a function, but nothing ever got 
added to the window.

Hitting q in the watch window closed it.

Should I be doing something differently?  Is this a bug?  This is the 
first time I tried to use the watch window.

I'm running  13.09-1 [git: 136742f6507eb946f8ff5351fa46541d0f5b82da] 
(from development awhile ago) with emacs 23.2.1 and R 3.0.1

Ross Boylan

More information about the ESS-help mailing list