[ESS] Problem with Rd-preview-help

David Scott d.scott at auckland.ac.nz
Mon Jan 6 01:15:36 CET 2014

I am using ESS 13.05 with Emacs 24.3.1 on Windows, Vince Goulet's 

I am trying to preview a .Rd file, using C-c C-p or M-x Rd-preview-help. 
I get an error:

Warning in file(con, "r") :
   cannot open file 
Invalid argument
Error in file(con, "r") : cannot open the connection
Execution halted

This used to work some time ago, but hasn't been working now for a 
while. I have just ignored it but was encouraged to think I might be 
able to sort it out by using the function debugging Vitalie helped me 
with recently. (Use C-u C-M-x on the function and step through with 
'n'). However when I go to Rd-preview-help in ess-rd.el, issue C-u 
C-M-x, then invoke Rd-preview-help, the debugger fails to operate, and I 
just see the error above. I also tried to run a back trace as in Section 
16.2 of the manual but no *Backtrace* buffer appeared.

I suspect this to be another Windows command line 'feature', because of 
the presence of lines

(setq shcmd (format "%s '%s'" Rd-to-help-command file))

and later

      (format "Rd-preview-help: (shell-command |%s| t)" shcmd))
(shell-command shcmd t)

C-h v Rd-to-help-command gives
Rd-to-help-command is a variable defined in `ess-rd.el'.
Its value is "R CMD Rd2txt"

I can process the .Rd file from emacs with

M-! R CMD Rd2txt filename.Rd

and get what seems to be the same result as I obtain on linux, so it 
doesn't seem to be a path problem.

David Scott

David Scott	Department of Statistics
		The University of Auckland, PB 92019
		Auckland 1142,    NEW ZEALAND
Phone: +64 9 923 5055, or +64 9 373 7599 ext 85055
Email:	d.scott at auckland.ac.nz,  Fax: +64 9 373 7018

More information about the ESS-help mailing list