[ESS] Unable to load development ess

Ross Boylan ross at biostat.ucsf.edu
Fri Sep 13 20:16:38 CEST 2013

I just synced up with the master branch of ess on github and don't seem
to be able to load ess.  I see nothing in *Messages* and there is no
*ESS* buffer.  None of the ess commands I've tried are recognized (e.g.,
auto-completion on ess- gets nothing, r-mode not recognized, esc-x r not
recognized).  My method of loading was working before (I haven't
refreshed in awhile, probably at least a month).

.emacs has
(let ((mydir "~/UCSF/Choi/GitHub/ESS/lisp"))
  (if (file-readable-p mydir)
    (setq load-path (append load-path (list mydir)))
    (load "ess-site")))

The setq load-path seems to have run.
emacs 23.4.1 on Debian.  The regular ess package was installed but is
now purged.

I have also tried executing the above code directly (C-x C-e).

I'm just starting to look into it (advice about how to do so would be
great), but I thought I'd report it because it's so serious.

Probably this is just a peculiarity of my local setup.

Ross Boylan

More information about the ESS-help mailing list