[ESS] ess-julia.el

Gustavo Lacerda guse at optimizelife.com
Sat Mar 2 19:46:29 CET 2013

First of all, I want to congratulate you guys for making this.

I just wanted to say that I was going down the same road as Jay,
trying to figure out why commands entered directly onto the julia REPL
don't echo (while commands sent to the REPL do).  After looking in the
wrong place for a bit, I found the checkmark: iESS menu > Process >
Process Echoes.  And now it works.... but if I restart emacs, I need
to set it again.

Is it a bad idea to edit ess-inf.el, line 2194?



P.S. I noticed that there is a tiny speck on the shell (which looks
like a low backquote), indicating the last command entered through the
shell (rather than thru ESS).  Is this an intentional feature?

On Sat, Feb 23, 2013 at 8:07 AM, Jay Kerns <gjkernsysu at gmail.com> wrote:
> Dear ESS-help,
> I have a few comments and questions about ess-julia.el:
> 1. Great work! Thanks for this.
> 2. I notice after M-x julia there is a 'load' statement which issues a
> warning about being deprecated and that 'require' should be used
> instead.  I found the place in ess-julia.el where that is (there looks
> to be 2 places, actually), and I fixed those, but I haven't committed
> to my fork yet because I wanted to ask about #3 first.
> 3. I notice after M-x julia that the process doesn't echo to the
> buffer.  I understand that in the iMenu there is a checkmark for
> "Process Echoes" and I can get the process to echo.  This is
> different, of course, from R (and gretl, it appears) which echo the
> process by default.
> I tracked it down to the following line in ess-inf.el:
> Line 2194 of /lisp/ess-inf.el
> (not (member ess-language '("SAS" "XLS" "OMG" "julia")))) ;; these don't echo
> So it looks like somebody deliberately wanted julia not to echo.  My
> question is, "Why?"  Is there a reason that would be easy to describe?
>  And if there is a reason, is there a setting I can use (in .emacs or
> elsewhere) to enable process echoes on my personal system?  (Yes, I
> can click the button, but it would be helpful in other work I'm doing
> for julia processes to echo by default).
> By the way, I've already tried numerous global settings, but since
> comint-process-echoes is buffer local that line "2194" overrides
> everything I've tried so far.
> Thanks again, and again, great work.
> --
> Jay
> ______________________________________________
> ESS-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list