[ESS] Fwd: ess sas interactive (remote)

Vinh Nguyen vinhdizzo at gmail.com
Fri Jun 14 17:44:43 CEST 2013

On Fri, Jun 14, 2013 at 7:05 AM, Rodney Sparapani <rsparapa at mcw.edu> wrote:
> On 06/13/2013 10:24 AM, Rodney Sparapani wrote:
>> So when you launch ess-sas-interactive you get ess-process-name-list
>> set to (("shell"))  But, when you have a .sas file and try to submit
>> a line then it becomes (("SAS") ("shell"))  Can we do something to
>> fix that?
> What is the intended way of fixing this?  I have tried setting
> ess-local-process-name, ess-language or ess-dialect:  all
> to no effect.  But, I only tried these one at a time.  Am I
> on the right track?  I guess not because nothing is working.

I think the trick is to set the sas buffer as an inferior buffer via
inferior-ess-mode.  Then in my sas file buffer, I can do C-c C-s to
switch to that process (it's listed now).  However, when trying to
send code with C-c C-r, C-c C-j, or C-c i, there is an error.  The
messages buffer shows:

Starting evaluation...
process-put: Wrong type argument: stringp, nil

The docstring of inferior-ess-mode seems to describe R/S, so maybe it
only works for that dialect?

-- Vinh

More information about the ESS-help mailing list