[ESS] ess-developer can't find just loaded library

Ross Boylan ross at biostat.ucsf.edu
Wed Apr 10 08:45:44 CEST 2013

> While trying to isolate my other problem I ran into a different one.
> One possibility is that these problems are a result of combining
> different versions of ESS.
Probably not.  I started with emacs --no-site and removed the line from my
personal .emacs file that executes the standard system startup.

I also tried enabling the developer mode (C-c C-t C-t) before loading the

In neither case did C-c C-t C-a recognize that silly was an available
name.  Nonethless, search() showed it on the path, and I was able to
execute functions from the package in the workspace after loading the

Very weird.

P.S. My .emacs file includes
(setq ess-use-tracebug t)
after loading ess.

> My local copy is 12.09-2, but the system
> has 5.11-1.  Because the system loads via a require my hope was that
> it would be a no-op since I load the local one first.  The only thing
> it looks as if the system does before the require is to add the system
> ess to the load path.  However, my personal copy's directory appears
> before the system one in the resultant load-path.
> Recipe:
> install attached silly library somewhere
> start ESS
> library(silly, lib="Rlib")
> C-c C-t C-t
> C-c C-t C-a
> the completion list in the minibuffer does not include silly.
> I've attached the library; I'm not sure if the attachment will come
> through.  It's a skeleton made by package.skeleton() + a couple of
> trivial functions, one of which calls the other.  I haven't touched
> the default NAMESPACE file, which I believe exports both functions.
> Using emacs 23.2.1.
> Ross

More information about the ESS-help mailing list