[ESS] Specifying locations of Rterm on Windows OS.

Josh O'Brien joshmobrien at gmail.com
Tue Sep 25 14:12:06 CEST 2012

On Mon, Sep 24, 2012 at 11:51 PM, Vitalie Spinu <spinuvit at gmail.com> wrote:
>   >> "Josh O'Brien" <joshmobrien at gmail.com>
>   >> on Mon, 24 Sep 2012 21:08:55 -0700 wrote:
>   > Hello again,
>   > I just downloaded the newly released ESS 12.09, and tried out feature
>   > referenced by Richard Heiberger, but can't seem to make it work for
>   > me. (I have successfully set the variable using the customize
>   > interface and directly using (setq ess-directory-containing-R "c:") on
>   > the line preceding my (require 'ess-site). For some reason, though,
>   > M-x R <tab> <tab> finds none of the versions of R stored in "C:/R/".
> The R versions are populated at startup (in ess-site). Place (setq
> ess-directory-containing-R "c:") before (load "ess-site") and it should
> be fine.

Changing from this:

(setq ess-directory-containing-R "c:")
(require 'ess-site)

to this:

(setq ess-directory-containing-R "c:")
(load "ess-site")

fixed it.

Not sure why that makes a difference (as ESS works well in all other
respects with the 'require'), but it certainly does.

Many thanks,


More information about the ESS-help mailing list