[ESS] Specifying locations of Rterm on Windows OS.

Martin Maechler maechler at stat.math.ethz.ch
Tue Sep 25 08:58:30 CEST 2012

>>>>> Josh O'Brien <joshmobrien at gmail.com>
>>>>>     on Mon, 24 Sep 2012 21:08:55 -0700 writes:

    > Hello again, I just downloaded the newly released ESS
    > 12.09, and tried out feature referenced by Richard
    > Heiberger, but can't seem to make it work for me. (I have
    > successfully set the variable using the customize
    > interface and directly using (setq
    > ess-directory-containing-R "c:") on the line preceding my
    > (require 'ess-site). For some reason, though, M-x R <tab>
    > <tab> finds none of the versions of R stored in "C:/R/".

    > What's odd is that I had been able to make this work with
    > the ESS 12.09 beta that I downloaded a day ago. In that
    > case, I edited line 540 of ess-site.el to read:

    >   (defcustom ess-user-specified-directory-containing-R "c:" ;; rmh

[well, I'm sure you also had a closing ")" but that's not the
 point, I know ...]

Hmm... the original  
        (if ess-microsoft-p  (defcustom .....) )
inside ess-site.el
gave warnings (and sometimes ?) errors during byte compilation.
We also had decided that in principle this variable should not
only exist for MS Windows even though it's currently made use of there.
For that reason, only a little before release, I had moved
the (defcustom .) part to where we typically have all (defcustom
.) entries :  ess-custom.el,  
and was happy that byte compilation worked without a warning.

But really this should not have affected the behavior as
ess-custom is loaded *from* ess-site.el *before*   
ess-directory-containing-R  is used...
so I am a bit puzzled.

    > and got just the behavior I was after.

    > Anybody have an idea what I might be doing wrong?

    > Thanks,

    > Josh

    > On Wed, Sep 19, 2012 at 1:54 PM, Richard M. Heiberger
    > <rmh at temple.edu> wrote:
    >> Your timing is perfect.  The newest release of ESS 12.09,
    >> which probably will be released next week, will provide
    >> the solution.  ESS through the current release on Windows
    >> finds all versions of R stored in the default
    >> installation location "C:/Program Files/R/".  Since you
    >> have a different location, the versions are not found.
    >> Once 12.09 is out, you will add a new line to your .emacs
    >> file prior to starting ESS. The exact phrasing is still
    >> in flux.
    >> On Wed, Sep 19, 2012 at 4:29 PM, Josh O'Brien
    >> <joshmobrien at gmail.com> wrote:
    >>> Hello,
    >>> I am using ESS version 12.04-4 on a Windows XP box, with
    >>> Vincent Goulet's installation of GNU Emacs 23.3.
    >>> I keep multiple versions of R in "C:/R"
    >>> (i.e."C:/R/R-2.14.2", "C:/R/R-devel", etc), and would
    >>> like to be able to select among them by typing "M-x R
    >>> <tab>". Based on the answer to this very similar
    >>> question
    >>> (https://stat.ethz.ch/pipermail/ess-help/2011-September/007137.html),
    >>> I know that the solution involves appropriately setting
    >>> either the ess-r-versions-created or
    >>> ess-rterm-version-paths variables, but I am having
    >>> trouble figuring out how exactly I should set them.
    >>> I store my ess customizations in a file
    >>> "~/.emacs.d/my-ess.el" that is included in my "~/.emacs"
    >>> by a call to (require 'my-ess). In both ".emacs" and and
    >>> "my-ess.el", both before and after the call to "(require
    >>> 'ess-site)", I have set ess-r-versions-created and
    >>> ess-rterm-version-paths like this (and many other
    >>> permuations as well, including using the customize
    >>> interface):
    >>> (setq ess-r-versions-created
    >>> "c:/R/R-2.14.2/bin/i386/Rterm.exe") (setq
    >>> ess-rterm-version-path(quote("c:/R/R-2.14.2/bin/i386/Rterm.exe"
    >>> "c:/R/R-devel/bin/i386/Rterm.exe")))
    >>> In no case, though, have I been able to get a version of
    >>> R to appear via tab completion after doing "M-x
    >>> R". ("M-x R-newest" also fails to find any version of
    >>> R.)
    >>> My question is this: Am I setting those variables
    >>> correctly, and if so, where else might I look for the
    >>> source of my problem?
    >>> Thanks,
    >>> Josh O'Brien
    >>> ______________________________________________
    >>> ESS-help at r-project.org mailing list
    >>> https://stat.ethz.ch/mailman/listinfo/ess-help

    > ______________________________________________
    > ESS-help at r-project.org mailing list
    > https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list