[ESS] Noweb problem after upgrade to ESS 12.09

Vitalie Spinu spinuvit at gmail.com
Fri Oct 12 13:53:05 CEST 2012

Ah, I forgot. This was reported before and has been fixed. 

For time being, before M-n s associate the buffer with the process first
(from the chunk C-c C-s). From there on, it should be fine.


  >> ottorino <ottorino-luca.pantani at unifi.it>
  >> on Fri, 12 Oct 2012 12:58:10 +0200 wrote:

  > Il giorno ven, 12/10/2012 alle 12.38 +0200, Vitalie Spinu ha scritto:
  >> This lines are not necessary. Rnw-mode is defined in ESS and you better
  >> not redefine it. Where did you get this idea from? If it's some public
  >> wiki place, then it should be deleted.
  > Sure I've found them somewhere.
  > They were in my .emacs since long time, but I cannot remember when I
  > added them

  > http://www.biostat.wisc.edu/~kbroman/Rintro/

  >> > I can see the 'M-x noweb-describe-mode' but there's no 
  >> > 'M-x noweb-font-lock-describe-mode'. 
  >> > The only modes are:
  >> This command was not there before, why would you need it?
  > I'm using emacs, but I'm not an expert. At least as not as you are.
  > Each time I get a message I try to read it and to get as much
  > information as possible to try to solve problems on my own.

  >> > On 'M-n-s' 
  >> > (that is "process this file with Sweave")
  >> > in the buffer 'messages' I get:
  >> It's not M-n-s it's "M-n s".  And what do you mean, that you cannot make
  >> it work?
  > Yes. My fingers were too fast in adding an extra "-".
  > But is the same command I can send from the drop-down menu

  >> Do C-h k M-n s  and see what M-n s is bound to. It should be
  >> ess-swv-weave.

  > These are the results

  > M-n s (translated from <escape> n s) runs the command ess-swv-weave,
  > which is an interactive compiled Lisp function in `ess-swv.el'.

  > It is bound to M-n s, <menu-bar> <Noweb> <Sweaving, Tangling, ...>
  > <Sweave>, <menu-bar> <Noweb> <menu-bar> <Sweaving, Tangling, ...>
  > <Sweave>.

  > (ess-swv-weave)

  > Run Sweave on the current .Rnw file.

  >> Try M-x ess-swv-weave and see if it work. 
  > I tried this suggestion and I get exactly the same as before

  >> > Finally I tried to comment out all the lines in my .emacs like this
  >> >> ;;  (defun Rnw-mode ()
  >> >> ;;   (require 'ess-noweb)
  >> >> ;;   (ess-noweb-mode)
  >> >> ;;   (if (fboundp 'R-mode)
  >> >> ;;       (setq noweb-default-code-mode 'R-mode)))
  >> This is the way to go. 
  >> Vitalie

  > I suspected it, and this is how I performed all the above commands

  > But still, I cannot get sweave to work from within emacs.

  > I can go from the shell, of course, but I would prefer to get back to my
  > old habits. M-n s then M-n P

  > Any other idea ?

  > ______________________________________________
  > ESS-help at r-project.org mailing list
  > https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list