[ESS] ESS on CentOS 5 throwing errors

Emmanuel Levy emmanuel.levy at gmail.com
Tue Aug 21 13:51:09 CEST 2012

Hi Brian and Vitalie,

I uninstalled both emacs and xemacs with YUM, and reinstalled both of
them. Re-did the ess install, but I still got the same error messages.
I also try to install all possible emacs add-ons (yum install emacs*)
and this did not improve things.

> emacs -Q

xemacs opens a new file called -Q and emacs  tells me ¨unknown option -Q ¨

> How does that look?
> What about commenting out the '(require 'ess-site)'
> and then evaluating it when emacs is open:
> M-: (require 'ess-site)
> ; or
> M-: (load "~/.emacs.d/ess-12.04-4/lisp/ess-site.el")

It gives me the same error ¨cannot find executable¨

I know things work well with Ubuntu, this is a desktop machine and not
a server so Iĺl just convince the IT person that I cannot allow myself
to loose days of work because of the OS. If ESS is trouble I cannot
even imagine what its going to be with packages that depend on many
uncommon libraries.

Thanks for your help,


> The degugging info may be more informative. If that doesn't help, I am
> guessing that compiling emacs on the certain OS will give you a solution. I
> base this on only good experience on multiple platforms when getting a
> working version of emacs and putting the ESS lisp code where emacs can find
> it, and firing it up, that is, merely following the instructions at
> ess.r-project.org.  This has worked for me on Windows, (X,L,K)Ubuntu, and
> Mac OSX. I am hard pressed to believe that it is a problem with ESS (or
> Emacs).
> Try that please.
> Best,
> Brian

More information about the ESS-help mailing list