[ESS] ? doesn't work

Marc Schwartz marc_schwartz at me.com
Wed Apr 25 20:08:51 CEST 2012

On Apr 25, 2012, at 12:46 PM, Alan S Barnett wrote:

> The help function doesn't work.
> I'm running linux.  If I run R from a terminal, help works properly.
> If I run it from emacs, a new buffer opens with an error message.
> Example:
> *R* buffer----------------------------------------------------------------------------------------------
> You are welcome to redistribute it under certain conditions.
> Type 'license()' or 'licence()' for distribution details.
>  Natural language support but running in an English locale
> R is a collaborative project with many contributors.
> Type 'contributors()' for more information and
> 'citation()' on how to cite R or R packages in publications.
> Type 'demo()' for some demos, 'help()' for on-line help, or
> 'help.start()' for an HTML browser interface to help.
> Type 'q()' to quit R.
> > options(STERM='iESS', editor='emacsclient')
> > ?predict
> >
> ---------------------------------------------------------------------------------------------------------------------
> *help[R](predict)* buffer--------------------------------------------------------------------------
> Error in help("predict", htmlhelp = FALSE) :
>  unused argument(s) (htmlhelp = FALSE)
> -------------------------------------------------------------------------------------------------------------------------
> I'm assuming an environment variable is not set correctly.  Any ideas?
> Thanks.

Search your .emacs for a line containing "htmlhelp", which is a deprecated option (circa R version 2.9.x).

You want to replace it with:

  (setq inferior-ess-r-help-command "help(\"%s\", help_type=\"html\")\n")

The ability to do this was modified circa ESS 5.5 as I recall.


Marc Schwartz

More information about the ESS-help mailing list