[ESS] Swankr

Sparapani, Rodney rsparapa at mcw.edu
Sat Dec 10 20:46:35 CET 2011

I've got a similar setup on OS X, i.e. no sbcl.  I get to this point...

After performing the installation steps above, M-- M-x slime RET R RET should start swank. You will be prompted to accept a version mismatch – simply accept – then the SLIME REPL should start up, giving a prompt. Enjoy!

But, I get no prompt....

So, then I tried M-x slime-connect
and now I do see a prompt, but I can't figure out how to send something to the prompt
from a .R file.  If I launch help.start(), then it looks at the host and port that I accepted
after slime-connect, but it doesn't seem to be working.  What am I missing?

From: Vitalie Spinu [spinuvit at gmail.com]
Sent: Saturday, December 10, 2011 10:39 AM
To: Christophe Rhodes
Cc: Sparapani, Rodney; Stephen Eglen; ess-help
Subject: Re: Swankr

On 10 December 2011 00:30, Christophe Rhodes <csr21 at cantab.net> wrote:
> I've fixed some rough edges, updated some text files, and pushed
> things to public repositories.  At
> <http://common-lisp.net/~crhodes/swankr/> there should be some updated
> instructions for getting started; it's still at the "some assembly
> required" stage, but hopefully to emacs veterans it's clear enough --
> please shout if some bits of the instructions don't actually work; I'm
> aware that reliable third-party deployment is hard.

I've tried your instructions on a machine without SBCL and I am getting:

Polling "/tmp/slime.29661".. (Abort with `M-x
slime-abort-connection'.) [3 times]
Connecting to Swank on port 4005..
Versions differ: 2011-12-10 (slime) vs. nil (swank). Continue? (y or n)
error in process filter: or: Can't find suitable coding-system
error in process filter: Can't find suitable coding-system

Any ideas?


PS: my slime setup:

(require 'slime)
(setq slime-net-coding-system 'utf-8-unix)
(slime-setup '(slime-asdf slime-repl slime-scratch slime-presentations
(setq slime-lisp-implementations
      '((R ("R" "--no-save" "--max-vsize=4096M")
           :init (lambda (port-filename coding-system)

keep.source=TRUE, chdir=TRUE)\nstartSwank('%s')\n" port-filename)))))

> Once you're up and running, playing with the repl should be fun; there's
> support for in-emacs display of lattice objects, for example, and the
> debugger support is relatively complete too -- so executions which
> generate errors will pop up an emacs debugger interface.  (It will take
> some getting used to, I imagine).
> I hope this gets you started.  Good luck!
> Cheers,
> Christophe

More information about the ESS-help mailing list