[ESS] Issue with error/warning messages in Emacs.app

Stephen Eglen S.J.Eglen at damtp.cam.ac.uk
Sun Jan 18 11:19:49 CET 2009

hi Vincent,
I've just tried your Emacs.app -- for me when I do M-x R, emacs seems to
hang, until I press C-g to quit.  I can then see that an *R* buffer has
been created, and after the copyright message for R, I see:

[Previously saved workspace restored]


So, those pesky ctrl characters are also preventing R from starting

Vincent Goulet <vincent.goulet at act.ulaval.ca> wrote:

> M-x getenv RET TERM RET gives "dumb". Doesn't look too good, heh?
> OTOH, in R,
> > Sys.getenv("TERM")
>    TERM
> "emacs"
> I confess I'm somewhat lost, here. What would be a good value? How do
> we set the TERM?

I see the same in your application.  BUT I'm not sure if we we need to
change the value of TERM.  I also have separately built emacs from CVS
sources a while ago, and in that Emacs, the TERM is also dumb, and yet I
see no problems running R (2.8.1).  The CVS Emacs I tried is from
2008-12-20, just using the nextstep flag, i.e. 
configure --with-ns

If it helps, I could tar up that Emacs for you and send it you to see if
it is a build issue... it would be great to have an ESS+Emacs for mac
users as well as you have done for Windows, and this is somethiing I
could help out with.  


More information about the ESS-help mailing list