[ESS] ESS and Windows 7

Rodney Sparapani rsparapa at mcw.edu
Tue Dec 29 17:24:22 CET 2009

On 12/26/09 04:42 PM, Edith Hodgen wrote:
> Hi
> I have a new computer operating under Windows 7 and am again facing the
> trials of getting Emacs, ESS, R and LateX to work. This time the problem
> seems to be around ESS and R (the rest, including spell checking, seems
> fine, and R works on its own, but not in ess/macs).
> I've been following the instructions on the sites aimed at the less
> competent, and have put ess here:
>   c:/devel/emacs/site-lisp/ess:
> and R here:
> c:/devel/R/R-2.10.1/bin:
> Running addpm.exe also didn't seem to work quite as I remembered it, and I
> had to go and make a short-cut to runemacs.exe. However, Emacs works, I get
> a LaTeX environment, and I can check spelling.
> I've used the pattern of my previous .emacs files, with modifications
> suggested for the newer releases.
> In particular, I've tried both versions of the first of the following
> sections (unsuccessfully)
> ==================================
> ;; ESS
> ;;(load "C:/devel/emacs/site-lisp/ess/lisp/ess-site")
> (require 'ess-site)
> ;; R
> (setq inferior-R-program-name "C:/devel/R/R-2.10.1/bin/Rterm.exe")
> (add-hook 'LaTeX-mode-hook 'turn-on-reftex)
> ====================================
> I tried editing the ess-site.el file (I remember having to do that in
> earlier versions), and leaving it as it was (equally unsuccessful).
> I then tried deleting the whole lot and downloading the GNU Emacs and ESS -
> All-in-one installation file for MS Windows, by Vincent Goulet, but for some
> reason, after downloading for several minutes, it went all shy and refused
> to save the file (more than once - I did try again). I put a copy of his
> site-start.el into the emacs/site-lisp directory and that also didn't
> perform magic.
> My PATH is:
> C:\devel\MiKTeX
> 2.8\miktex\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\C:\tools\bin;C:\devel\emacs\bin;C:\devel\texmf\miktex\bin;C:\devel\ghostgum\ghostview\gsview\;c:\usr\local\bin;C:\devel\ghostgum\gs\gs8.51\lib;C:\devel\ghostgum\gs\gs8.51\bin;C:\devel\MinGW\bin;c:\devel\Aspell\bin;C:\devel\R\R-2.10.1\bin
> I've double, triple, and quadruple-checked spelling everywhere (which means
> I've probably overlooked something), and have searched on the Internet for
> clues. I saw one other query about Windows 7, but that resolved itself, so
> my guess is that it *should* work.
> In Emacs, M-x R causes the message: [No match]
> and there is no *ESS* buffer.
> Any assistance will be extremely gratefully received.
> Edith

Hi Edith:

I feel your pain.  However, I don't think very main ESS users have taken 
the plunge to 7 yet.  I'm still using XP.

Happy Holidays,


More information about the ESS-help mailing list