[ESS] R - Help buffer

gerald.jean at dgag.ca gerald.jean at dgag.ca
Mon Oct 20 16:43:40 CEST 2008


I am a long time user of Splus through ESS (thanks for such a good
package), mostly on Unix/Linux machines.  Recently we have installer R on
our Linux Red Hat machine.  R started right out of the box with "M-x R".  I
have a hard time though getting the help pages show up in an Emacs buffer?

When running Splus through ESS, C-c C-v will prompt me for a help topic and
when I type a topic it will show up in a new Emacs buffer, exactly what I

But when I run R through ESS, C-c C-v will still prompt me for a help topic
but when I type a topic what shows up in the *help[R] fct. name* buffer is:

Error in help("glm", pager = "slynx -dump", window = F) :
  unused argument(s) (window = FALSE)

I tried setting the "pager" and the "help.pager" options to "emacsclient",
as they are when running Splus but to no avail, I still get the same error.

By typing

> help.start()

I can still get the HTML browser interface to help but I do prefer Emacs'
buffers by a long shot.

Thanks for any suggestions,

Gérald Jean
Conseiller senior en statistiques,
VP Planification et Développement des Marchés,
Desjardins Groupe d'Assurances Générales
télephone            : (418) 835-4900 poste (7639)
télecopieur          : (418) 835-6657
courrier électronique: gerald.jean at dgag.ca

"In God we trust, all others must bring data"  W. Edwards Deming

Le message ci-dessus, ainsi que les documents l'accompagnant, sont destinés uniquement aux personnes identifiées et peuvent contenir des informations
privilégiées, confidentielles ou ne pouvant être divulguées. Si vous avez reçu ce message par erreur, veuillez le détruire.

This communication ( and/or the attachments ) is intended for named recipients only and may contain privileged or confidential information which is
not to be disclosed. If you received this communication by mistake please destroy all copies.

More information about the ESS-help mailing list