[ESS] help() and library() in R return "... cat: not found"

N. Eiji Nawa globusbogus at yahoo.co.jp
Wed Mar 5 09:12:04 CET 2008


this is my first post to ess-help (a great software by the
way!). I must say first that I am not quite sure my
problem can be solved within ess (apologies in advance if
that's the case). Let me first describe my system:

ess 5.3.6
Mac OS X 10.4.11 (G5)
GNU Emacs
R 2.6.2

I am having trouble viewing the R help files from within
ess/emacs. This is what happens. When I type


a second buffer (named *help[R](read.table)*) opens up but
with an error message

/Library/Frameworks//R.framework/Resources/bin/pager: line
10: exec: cat: not found

When I type


I get exactly the same message as above but now in R's
main buffer (*R*).

Both commands work fine if I run R from a terminal window
(like xterm) or from the GUI version of R.

What is puzzling me the most is that if I open a shell in
emacs, run R, and try help(read.table) or library(), I get
the correct results.

I first thought it was something related to environment
variables, so I first defined R_HOME as
/Library/Frameworks/R.framework/Resources but it didn't
work. Then I defined R_ENVIRON as
but got the same output as before.

If you have seen this before or have an idea on how I
could nail this down in more details, I will be happy to
hear from you.

Thank you very much in advance!

N. Eiji Nawa

More information about the ESS-help mailing list