[ESS] R Problem: install.packages() in NTEmacs 21.3 with ESS 2.3.5.

Wei Tang william.wtang at yahoo.com
Mon Nov 13 07:11:26 CET 2006

Hi All,
I got a R problem when issuing the command 'install.packages()' within NT Emacs 21.3 + ESS 2.3.5. The Emacs freezes after this command.
I've already searched this mailing list for a solution. I found the same problem was reported in 2005 archives. The problem could be solved by issuing 'library(tcltk)' or 'windows()' first. But I don't think this is a nice solution. I found another trick, which is to cancel the install.packages() at the first time by "C-c C-c" and re-enter this command again, then the CRAN mirror site selection windows will be pop-up. However, this solution is also not satisfiable.
I think this is a bug from ESS instead of R since there is no such problem when I use Rgui or Rterm alone. It is a big surprise to me that the latest ESS still contains such a problem.  I wonder if there is anyone who has already solved this problem. Thanks.

More information about the ESS-help mailing list