Starting an S Process with Arguments

Ed Kademan kademan at
Thu Nov 21 18:44:16 CET 2002

rossini at (A.J. Rossini) writes:

> >>>>> "ed" == Ed Kademan <kademan at> writes:
>     ed> How does one start an S process with arguments?  I am using GNU Emacs
>     ed> 21.1.1 and Splus6 on Solaris and want to run "Splus6 -j".  I have
>     ed> tried putting
>     ed>   (setf inferior-S+6-args "-j")
> setq?

I use the cl package which defines setf.  For a line like the above
setf and setq are equivalent.

>     ed> in my .emacs and starting S by typing "M-x S+6" but this doesn't work.
> We could edit the R startup to allow for it.

Are you acknowledging that there is a bug that needs fixing?  Or are
you telling me that I should edit the "R startup"---whatever that is?

The documentation for ess mode says that you can pass arguments to the
executable by specifying them in the variable
`inferior-S_PROGRAM_NAME-args' (where you replace S_PROGRAM_NAME with
the program name).  This doesn't work, and I guess I'm suggesting that
at the very least you delete that paragraph.

By the way, I tried following David Brahm's advice by doing
  (custom-set-variables '(inferior-ess-start-args "-j"))
but this only worked as long as I used Splus and nothing else.  After
starting up an R process the `inferior-ess-start-args' variable became
the empty string "" and subsequent Splus sessions did not get the "-j"

More information about the ESS-help mailing list