ESS, Redhat Linux 6.1, and Emacs 20.4

Edward J. Czilli ejczilli at
Sat Feb 12 21:37:12 CET 2000

I downloaded the ESS package yesterday, but I am having trouble 
installing it.  I need to know how to add ESS to Emacs under Linux. 
 I have configured Emacs and AUCTex under Win98/NT, but the set-up 
of Emacs and related packages under Linux is new to me.  

I have read the ESS-5.0-README file, but I continue to have 

The file structure under Linux is confusing me. I hope that you can 
clarify things a bit for me with respect to the Emacs organization 
under Linux.

I have a fresh install of Redhat Linux 6.1 and Emacs 20.4 was 
installed as part of the Rehat install procedure (using, I assume, 
the rpm). This is a single user workstation setup. 

It appears that Emacs has created directories in the following 
/usr/local/bin/emacs				(binary files)
/usr/local/share/site-lisp			(this is an empty directory) 
/usr/local/share/emacs/20.4/... 	(LISP code and support files) 
/usr/local/info 						(INFO files for Emacs)

PROBLEM #1: Where is the '.emacs' file located?

Should it be placed in /usr/local/share/emacs/20.4?  I have been 
told that '.emacs' should be placed in 'my root directory'.  Is 
/usr/local/share/emacs/20.4 the 'root directory'?

PROBLEM #2: Locations of LISPDIR and INFODIR

This is a source of much confusion for me...  It looks like I have 
two ../site-lisp subdirectories:

What purpose is served by two ../site-lisp subsirectories?

The ESS-5.0-README says to extract the ESS *.tar file in a 
directory 'where I keep lisp files.'  I extracted the *.tar file to 
/usr/local/share/emacs/20.4/site-lisp. Was this the correct thing 
to do?

It looks like I have two info subdirectories:
/usr/info 			(contains the 'dir' file)

When I ran the ESS Makefile, ESS placed the ESS info files in 
/usr/local/info. How can I edit /usr/info/dir to tell Emacs where 
to find the ESS info files?

Problem #3: Getting Emacs to 'see' the ESS Lisp code.

I created a '.emacs' file in /usr/local/share/emacs/20.4 and put a 
line in it as follows:


But when I run Emacs I cannot be certain if Emacs read the line. In 
any case, Emacs does not respond to any of the ESS commands. I have 
R insttalled on my system and I want ESS to work with R.  But when 
i type M-x R nothing happens.  So I must be doing something 

Can you offer anysuggestions?  Thank you for your time.

ess-help mailing list -- To (un)subscribe, send
subscribe	or	unsubscribe
(in the "body", not the subject !)  To: ess-help-request at

More information about the ESS-help mailing list