[ESS] Issue with polymode installed from ELPA

Sparapani, Rodney r@p@r@p@ @end|ng |rom mcw@edu
Fri Sep 20 18:16:41 CEST 2019

> Just to clarify that none of those requires is really needed unless you install polymode and poly-xyz
> from the source and want to load from special locations. If installed from melpa, everything
> (including file associations) should work out of the box. No configuration needed whatsoever.
> Dependencies will be resolved automatically because elpa packages are already in the path.

>  Vitalie

Hi Vitalie:

Well, I hate to burst your bubble.  But, I can assure you, that FOR ME polymode does absolutely
nothing if you do not require it.  And I just tested that again.  This problem is what inspired my bug
report (see below from 9/9) to which I received no advice ;o(



Hi Gang:

I am stumped.  I tried to install polymode from ELPA into Vincent Goulet's
distro of Emacs and ESS (it no longer contains polymode sadly).
macOS 10.14.4 Mojave, Emacs version 26.2 and ESS version 18.10.2
The ELPA install seemed to go well.  My load-path starts with
"/Users/rsparapa/.emacs.d/elpa/polymode-0.2" ...
So, everything looks good.  But, I get errors when I put simple requires in
.emacs like (require 'polymode)
So, I hard-coded all of the paths, but this gets hairy since now I have to
hard-code all of the dependencies too ...
(require 'polymode-classes "~/.emacs.d/elpa/polymode-0.2/polymode-classes.el")
(require 'polymode-core "~/.emacs.d/elpa/polymode-0.2/polymode-core.el")
(require 'polymode-compat "~/.emacs.d/elpa/polymode-0.2/polymode-compat.el")
(require 'polymode-methods "~/.emacs.d/elpa/polymode-0.2/polymode-methods.el")
(require 'polymode-export "~/.emacs.d/elpa/polymode-0.2/polymode-export.el")
(require 'polymode-weave "~/.emacs.d/elpa/polymode-0.2/polymode-weave.el")
(require 'polymode-base "~/.emacs.d/elpa/polymode-0.2/polymode-base.el")
(require 'poly-lock "~/.emacs.d/elpa/polymode-0.2/poly-lock.el")
(require 'polymode "~/.emacs.d/elpa/polymode-0.2/polymode.el")
(require 'poly-noweb "~/.emacs.d/elpa/poly-noweb-0.2/poly-noweb.el")
(require 'poly-markdown "~/.emacs.d/elpa/poly-markdown-0.2/poly-markdown.el")
(require 'poly-R "~/.emacs.d/elpa/poly-R-0.2/poly-R.el")
Getting the order of the dependencies right was a pain as well.  However,
brute force fixed it!  But, I don't want to go through this ever again for
obvious reasons.  It took me over an hour for what is supposed to be a 5 or
10 minute install.  Does anyone have an idea of WTF is going wrong here?



	[[alternative HTML version deleted]]

More information about the ESS-help mailing list