[ESS] Emacs ESS cannot find R onmacos 10.12.6

Stephen Eglen @je30 @end|ng |rom c@m@@c@uk
Wed Sep 13 23:18:02 CEST 2017

hi Robert,

try the following steps and do report back

1. On your mac, open terminal and start R from within the terminal.  if
that works, what does "which R" report?  

2. If 1 worked, open Emacs from within this terminal, and then do

M-x shell

to get a terminal within Emacs.  Does "R" work now, and if so, is it
finding the right version of R (which R)?

If it doesn't find R, ESS probably won't work either.  Check your PATH
within Emacs.

[I'm not sure Emacs will find R if you start Emacs from the "floating
bar" thing, rather than from within a terminal, as you need to ensure
your PATH etc is set up for Emacs to inherit it.]

3. If step 2 worked, M-x R should work.

If not, what does it say?

On Wed, Sep 13 2017, Robert Baskin wrote:

> I cannot get Emacs ESS to find R.
> The error message:
> "Finding all versions of R on your system...
> Sorry, no version of R could be found on your system."
> I can’t find any message on ess-help and the only similar message I can find on SO:
> <https://stackoverflow.com/questions/31365411/how-to-invoke-ess-r-in-emacs-on-windows>
> I have tried reloading Emacs ESS:
> "GNU Emacs 25.2.1 (x86_64-apple-darwin13.4.0, NS appkit-1265.21 Version 10.9.5 (Build 13F1911))
>  of 2017-04-21
> Copyright (C) 2017 Free Software Foundation, Inc."
> downloaded from:
> <https://vigou3.github.io/emacs-modified-macos/>
> I have updated R:
> "R version 3.4.1 (2017-06-30) -- "Single Candle"
> Copyright (C) 2017 The R Foundation for Statistical Computing
> Platform: x86_64-apple-darwin15.6.0 (64-bit)"
> The macOS is Sierra, v10.12.6.
> Any suggestions on how to solve this?
> thanks - bob
> ______________________________________________
> ESS-help using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list