[ESS] starting directory not detected correctly anymore

Paul Johnson p@u|john32 @end|ng |rom gm@||@com
Mon Dec 4 23:21:05 CET 2017

I was running the dev version of ESS in Melpa. I cleared that out.

With Ubuntu Emacs 24.5, I still see the trouble. However, problem
disappeared with Emacs 25.1, which I notice is now available in the
standard Ubuntu repository. Rodney S wrote and said he did not see
problem in RedHat with Emacs 25.2, that's why I tried that.

I have tested this repeatedly with emacs25 and all is good.  With
emacs24, however, same problem exists.

For me, problem is solved by updating Emacs, but if you want some
debug info, point me at directions to get you what you need and I will
do that.


On Sat, Dec 2, 2017 at 12:20 PM, Lionel Henry <lionel.hry using gmail.com> wrote:
> Startup in the project/package root is experimental and isn't
> enabled by default.
> Is it possible you are using a dev version from a month or so ago?
> For instance you could have installed it with melpa. The released
> version or the current dev version should not exhibit that behaviour.
> Best,
> Lionel
>> On 2 déc. 2017, at 18:43, Vitalie Spinu <spinuvit using gmail.com> wrote:
>> I think this is a consequence of the recent feature which sets the default
>> directory to the package directory. It looks like it treats your tmp directory
>> as a package. @Lionel?
>>  Vitalie
>>>> On Thu, Nov 30 2017 18:59, Paul Johnson wrote:
>>> Greetings.
>>> I want to have ESS know the working directory from shell pwd, I don't
>>> want it to ask me.
>>> I have a setting in my init.el that used to work that way:
>>> ;; start R in current working directory, don't let R ask user:
>>> (setq ess-ask-for-ess-directory nil)
>>> Recently, it has stopped working. The symptom of the problem is that
>>> the R session working directory trims off the last element in the
>>> path. This is in Ubuntu 17.04 with emacs 24.5.1 and ess 17.11.
>>> When I open a file from command line, say in
>>> $ cd ~/tmp/R/
>>> $ emacs testme.R
>>> and then I hit the bug blue icon to start R, then getwd() shows
>>> "~/tmp". The last element in the path is lost.  Same happens if I
>>> start R with "Alt-x R", so don't hate me for liking your pretty blue R
>>> button.
>>> I notice that M-x eshell gets it right, it opens a shell in the /R
>>> directory (the correct one). Also Emacs File "Open Directory" also
>>> gets it right. Its just the inferior ESS *R* session that doesn't get
>>> it right.
>>> If I remove that line from init.el, then the ESS process stops and
>>> asks me what directory what I want and it always guesses correctly.
>>> I never saw this happen before today when opening a pre-existing R
>>> file from the shell.  I have seem similar in past if I have an Emacs
>>> session open and close the R session and re-start a new R session
>>> without closing Emacs.  That second instance almost always has lost
>>> the "R" from the file path, and shows the parent directory.
>>> Would somebody try it and tell me if I've just gone all the way off
>>> the cliff toward crazy?
>>> Suggestions welcome (except concerning cliffs), thanks as usual.
>>> pj
>> ______________________________________________
>> ESS-help using r-project.org mailing list
>> https://stat.ethz.ch/mailman/listinfo/ess-help

Paul E. Johnson   http://pj.freefaculty.org
Director, Center for Research Methods and Data Analysis http://crmda.ku.edu

To write to me directly, please address me at pauljohn at ku.edu.

More information about the ESS-help mailing list