[ESS] Interactive SAS mode hangs

Erin Jonaitis jon@|t|@ @end|ng |rom |@tr|-w|@org
Tue Sep 1 17:46:28 CEST 2015

Thanks, Rodney. Things I have learned!

1) I actually can recover from one of these crashes (in M-x SAS) with C-g. Strange! No other keypress or mouse interaction works during those crashes (that I have found). Sometimes that gives me a useful error message (it turns out I have a permissions problem on one dataset I was trying to access). Sometimes it doesn't.
2) I also tried ess-sas-interactive just now, and the crashes don't happen there, which is great. I still can't run a data step properly, though -- if I try to create WORK.WANT using a datalines; statement, it will get the data structure right, but won't read the data in, telling me I have 2 variables (e.g.) and 0 observations. Trying to overwrite the same dataset gives me the opaque message, "WARNING: Data set WORK.WANT was not replaced because this step was stopped."

What is the difference between ess-sas-interactive and M-x SAS? It seems like maybe when I run SAS via the latter process, ESS hangs every time I get an error message back from SAS or something. That's obviously not desired behavior in and of itself. Not being able to get through a datastep even when the hanging is not happening (i.e. in ess-sas-interactive) is also a problem, but might be a separate problem.


----- Original Message -----
From: "Sparapani, Rodney" <rsparapa using mcw.edu>
To: jonaitis using fstrf-wi.org
Cc: "ess-help" <ess-help using stat.math.ethz.ch>
Sent: Tuesday, September 1, 2015 10:08:48 AM
Subject: Re: Interactive SAS mode hangs

> I did as you suggested, and one thing I learned is that the same crashing pattern happens (S mode works, but
> SAS mode crashes emacs when I try to submit code). That's useful because it tells me it's not due to
> something else bad in the init file. Unfortunately, I can't seem to find a file containing backtrace
> information. Does the underlying Linux system need to be set up in a certain way to produce such a file?
> Should I expect it to in ~/.xsession-errors, or could it have another name or location?
> Erin

Well, I was hoping that you would see a backtrace before the crash.
The crash info goes into core files, but I don't know if that would
be of much use since you would need to have the debugging info loaded
which can be a pain.  Did you try M-x ess-sas-interactive?

More information about the ESS-help mailing list