[ESS] Questions on Section 3.3

Marius Hofert m@r|u@@ho|ert @end|ng |rom uw@ter|oo@c@
Tue May 19 13:05:18 CEST 2015

Hi Vitalie,

thanks a lot for helping, 'tramp-remote-path' was the point. By
default this points to the local path instead of the remote one, so
after setting (add-to-list 'tramp-remote-path 'tramp-own-remote-path)
in .emacs it worked on my other testing server. The first server I
tried is currently still out of service, but it should work there,
too, now. If not I'll let you know.

Thanks again for helping!

Many cheers,

On Mon, May 18, 2015 at 11:30 PM, Vitalie Spinu <spinuvit using gmail.com> wrote:
>  >>> Marius Hofert on Mon, 18 May 2015 18:39:40 -0400 wrote:
>  > What do you mean by R's prompt? Of course, if I ssh onto the machine
>  > and then start R by typing 'R', I get a normal R prompt "> ".
> That's what I mean.
>  > The *ESS* buffer shows what you describe below (556 lines of output
>  > and then "(inferior-ess: waiting for process to start (before hook)").
>  > Now if I switch to the *R* buffer, it shows:
>  > env: R: No such file or directory
> Your R program is not found. You should add the directory where R is
> located to `tramp-remote-path`.
>  > Is the R process supposed to run locally but being associated to the
>  > script on the remote machine or is the R process supposed to run on
>  > the remote machine?
> All remote processes run on the remote, otherwise they won't be called
> so. ESS asks TRAMP to start a remote R and communicates with it through
> TRAMP afterwards.
>   Vitalie

More information about the ESS-help mailing list