[ESS] A bad help request

Dr. Michael L. Dowling Mike.Dowling at t-online.de
Sat May 16 17:04:46 CEST 2015

Hello ESS mailing list!

I'm afraid that  this will be a  very poor help request as  I simply was
not methodical enough  to record exactly what I did  and where.  I would
fully understand if nobody can respond.

I have been using  emacs now for decades and ESS for  about 10 years.  I
use Arch Linux.  Towards the end of April emacs-24.5 was released.  When
I started emacs, it  behaved as though it just stopped  in the middle of
loading,  and could  only  be stopped  with  a "kill  -9"  on the  emacs
process.  I eventually realised that ESS was the culprit; comment it out
of my .emacs file, and everything was  fine, except that I could not use

Now, I work in Hamburg, where I  have no Internet, but return to my flat
in Braunschweig  during the weekends.   I decided  to look into  this in
Hamburg.  But  to my immense surprise,  it worked just fine  in Hamburg.
But my Hamburg PC is an identical  copy on the Braunschweig PC; even the
same hardware.  They are mutual backups of one another.

Back in Braunschweig,  I turned off my router, and  bingo, emacs started
normally.  Keep the router on but  turn off my firewall, emacs starts as
it should.   Then I realised  that emacs was  not dead, but  instead was
trying communicate via the Internet and was being stalled with time-outs
resulting from the firewall.  Wait long enough, and emacs would start.

This is  odd!  Everything  I would ever  want to do  on the  Internet is
permitted.  Things  like initiating  a TCP  connection from  outside are
not, with the exception of passive FTP which is permitted.

I have since updated my  ESS package.  However, initially also suspected
the icicles package, so I upgraded that as well.  Then everything worked
as it should, here in Braunschweig  with the Internet and firewall.  But
not in Hamburg.  These I had  to create a sub-directory of ess/etc/ESSR,
I forget which.

What I  suspect is that ESS  tries to check with  the repository perhaps
with a view  to automatically updating (which would not  work as with me
ESS is centrally installed by root).   But that would be permitted by my
firewall!  Why does  ESS behave  differently with  and without  Internet

Personally, I  like to know when  software connects to the  Internet and
would  like to  give  my  explicit consent  to  it  happening.  Is  this
configurable in the ~/.emacs file?

Sorry  if  this is  too  vague;  I was  not  very  professional with  my
activities  to  document them  properly.   I  thought I  could  remember
exactly what  I did in  Hamburg and what I  did in Braunschweig,  and so
construct a  report.  In the  end, my memory  lapsed.  All the  same, if
anybody has any suggestions, I would appreciate them.

Mike Dowling

Dr. Michael L. Dowling
Gaußstr. 27
38106 Braunschweig

More information about the ESS-help mailing list