[ESS] Multiple R versions not recognized on M-x R-[Tab]

Marius Hofert marius.hofert at uwaterloo.ca
Thu Apr 2 21:50:34 CEST 2015


I work on Debian Testing and installed ESS (M-x ess-version gives: 15.03 [git:
6cbe608018deda6fa5608735c821094a553dd55c] (loaded from
/usr/share/emacs/site-lisp/ess/)) and have several R version installed. However,
I don't see them via M-x R-[Tab].

I saw this post:
and https://stat.ethz.ch/pipermail/ess-help/2011-September/007137.html
but neither gives precise instructions how to get the 'automagically determine R
versions' feature.

Here are some more details:
- Emacs 24.4.1
- M-x ess-r-versions-created gives /usr/local/R/R
- M-x ess-rterm-version-paths gives nil
- M-x R-[Tab] gives:

Possible completions are:
R-fix-T-F R-initialize-on-start
R-mode R-site-search

Judging from the second post above, I tried this:

(setq ess-rterm-version-paths "/usr/local/R/R"); for finding all
installed R versions

... but M-x R-[Tab] still gives the same output as before

Concerning R installation, I installed from source in /usr/local/R:

  total used in directory 55M available 147988960
  drwxr-sr-x 130 mhofert mhofert 4.0K 2015-04-01 22:52 library
  lrwxrwxrwx   1 mhofert mhofert   32 2015-03-31 15:57 R ->
  drwxr-sr-x  15 mhofert mhofert 4.0K 2015-03-31 15:52 R-3.1.3_build
  drwxr-sr-x  10 mhofert mhofert 4.0K 2015-03-09 04:12 R-3.1.3_source
  -rw-r--r--   1 mhofert mhofert  28M 2015-03-09 04:12 R-3.1.3.tar.gz
  drwxr-sr-x  15 mhofert mhofert 4.0K 2015-04-02 15:16 R-devel_build
  drwxr-sr-x  10 mhofert mhofert 4.0K 2015-04-01 21:20 R-devel_source
  -rw-r--r--   1 mhofert mhofert  27M 2015-04-02 15:08 R-devel.tar.gz

[this is a setup very similar to Martin has (I guess) -- he showed it to me once
and it has worked well ever since :-)]

Many cheers,

More information about the ESS-help mailing list