[ESS] Using ESS with S-plus 8.1

Richard M. Heiberger rmh at temple.edu
Fri Nov 7 01:09:40 CET 2014

The etiquette of this list is to stay on the list.  I am ccing the
reply to the list.

On my 64-bit Windows 8.1 with ESS 13.09-2



M-x S on Windows doesn't work with current ESS.  That is part of what
we need to repair.

Do you have your S-Plus in a non-standard location?

If you get a message about sh, that means you don't have cygwin on your
In that case you need to use
M-x S+6-msdos-existing
It still won't work with current ESS for talking to the S-Plus (S+) GUI.
It doesn't crash.  It just locks up emacs.  Use C-g a few times to unlock it.

Until the repair is made, you will have to use an older ESS.
You can get the older ESS from the site
click on the Download tab, and then on the archive link.

As I wrote yesterday, ESS 5.14 works in your situation.

M-x Sqpe opens an *S+* buffer in iESS mode.  It has a running S+ in it.
You can type directly or you can use C-x C-n commands from your myfile.s
in ESS[S] mode.


On Thu, Nov 6, 2014 at 6:36 PM, Tayler Lawrence Jones
<t.jonesd289 at gmail.com> wrote:
> Thanks for the insight Richard!
> When I run M-x Sqpe, a *S+* buffer does open, but it does not have an S+
> process; it just appears to be a mode-less text editing buffer.
> I did receive this error:
> S+: The emacs variable `inferior-S+-program-name' does
> not point to S-Plus 6 or 7 or 8.  Please add `splus[678]?/cmd' (expand the
> `[678]?' to match your setup) to your `exec-path' or specify the complete
> path to `Splus.exe' in the variable `inferior-S+-program-name' in your
> `.emacs' file.
> So I made that edit to my .emacs (before I had just been setting
> 'inferior-S-program-name", without the "+"). Now when I try M-x S, I get
> this error:
> "apply: Searching for program: permission denied, sh". I am the only user on
> this computer and have full permissions, so I don't know why I would get
> this error.
> M-x S+6msdoes-existing still leads to a hang up and crash.
> I will keep playing around to try and get this to work... I know there must
> be a way!
> Thanks again!
> On Wed, Nov 5, 2014 at 9:10 PM, Richard M. Heiberger <rmh at temple.edu> wrote:
>> I am now at home on a Windows 8 machine.
>> M-x Sqpe with current ESS starts S+ correctly.
>> There is a nuisance behavior.  You must manually switch to the *S+*
>> buffer.
>> M-x S-existing in current ESS is not working.  I don't understand why,
>> but I have a workaround.
>> Back up to an old ESS.  I used 5.14.
>> Then M-x S+6-msdos-existing has the anticipated behavior.
>> It talks to the already running S+ 8.2 GUI process.
>> The specific behavior that is wrong is that the current ESS opens *S+* in
>> iESS
>> mode.  For the purpose of talking to an S+ GUI, the correct behavior is to
>> open *S* in ddeESS mode.
>> I will report back to the ESS-help list once we figure this out and repair
>> it.
>> Rich
>> On Wed, Nov 5, 2014 at 9:03 PM, Richard M. Heiberger <rmh at temple.edu>
>> wrote:
>> > It works fine for me.
>> >
>> > I just did M-x Sqpe on a vista system and all is well.
>> >
>> > I will try again at home with Windows 7 and 8.  I expect that it will
>> > work.
>> >
>> > M-x S+6-existing has been giving me problems for a while.  My solution
>> > is to use M-x Sqpe
>> >
>> > On Wed, Nov 5, 2014 at 5:28 PM, Tayler Lawrence Jones
>> > <t.jonesd289 at gmail.com> wrote:
>> >> Hello all,
>> >>
>> >> I'm working on a project that is in S+ 8.1, and I am using Windows 7
>> >> with
>> >> the latest packaged ESS from Vincent. The folder to splus.exe and
>> >> sqpe.exe
>> >> is in PATH.
>> >>
>> >> Is there anyway to get that version of S+ running in ESS?
>> >> R works no problem. S+, however, is nothing but trouble.
>> >>
>> >> M-x S tells me to run from icon, then use M-x S-existing.
>> >> Doing so with M-x S-existing causes emacs to hang up and crash.
>> >> M-x Sqpe lets me select a starting directory, but then gives the error
>> >> 'spawning child process: invalid argument' and nothing happens.
>> >>
>> >> I have tried adding these lines of code to my .emacs file (based on
>> >> some
>> >> outdated mailing list threads), but the result is the same:
>> >>
>> >> (require 'ess-site)(setq-default inferior-S-program-name "C://Program
>> >> Files (x86)//TIBCO//splus81//cmd//SPLUS.exe")(setq-default
>> >> inferior-Sqpe-program-name "C://Program Files
>> >> (x86)//TIBCO//splus81//cmd//sqpe.exe")
>> >>
>> >> Note: I have tried with single slashes as well.
>> >>
>> >> I get the same result if I do S+6, Sqpe+6, etc.
>> >>
>> >> Does anyone know if this is even possible? I am an emacs fiend, so it
>> >> drives me crazy that S+ won't work in ESS for me.
>> >>
>> >> Thanks for any help!
>> >>
>> >> PS - I am in the process of porting the code to R, but it needs to be
>> >> utilized in the interim. So, unfortunately, just using R is not an
>> >> option
>> >> right now.
>> >>
>> >>         [[alternative HTML version deleted]]
>> >>
>> >> ______________________________________________
>> >> ESS-help at r-project.org mailing list
>> >> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list