[ESS] ess-remote double echo

Vitalie Spinu spinuvit at gmail.com
Fri Mar 28 18:25:57 CET 2014

Ross' problem happens with ess-eval-visibly set tot t. I was wondering
why I don't see that. Should not be; will check that. Your problem is
because you are not using comint, but setting comint-process-echoes as a
local var should in principle work.

 >>> Sam Steingold on Fri, 28 Mar 2014 11:37:45 -0400 wrote:


 > I observe the same behavior with emacs/term/screen/ess as described
 > in http://stackoverflow.com/a/22703777/850781Setting
 > comint-process-echoes to t does not help even after I tell
 > inferior-ess-input-sender to ignore it.

The code works for me. I would like to streamline this and completely
bypass ess-remote. Something along M-x ess-connect then chose local or
remote R from a menu. Last time I tried to implement this I got stuck by
control characters from screen:

     [56CType 'demo()' for some demos, 'help()' for on-line help, or
     [21C'help.start()' for an HTML browser interface to help.
     [74CType 'q()' to quit R

      Loading required package: grDevices
     > 343 + 34
     [1] 377

I still see them if I run screen from shell, but not with term-exec as
in your example. This is the way to go, indeed.

Do you experience other problems with term-exec besides the double


More information about the ESS-help mailing list