[ESS] problems with ess-remote in git

Ross Boylan ross at biostat.ucsf.edu
Sat Apr 5 01:02:53 CEST 2014

On 4/4/2014 3:23 PM, Vitalie Spinu wrote:
> I cannot reproduce the problem exactly but there was a small problem
> with loading ESSR.rda with ess-remote. I have tried to address it. Could
> you please pull git up and check if it solves your issue?
Slightly better.  Usually if I'm in shell mode and launch under MPI, 
ess-remote works (but sometimes it doesn't).  Usually if I'm in iEss 
mode (i.e., in a shell after I've exited a remote ess session, but 
before M-x shell-mode) it doesn't work (I'm not sure if it ever worked 
in my tests).

Using git f9722bd

As you probably know the "Type C-h m for help on ESS Version 13.09-2" 
also appears after successful execution of ess-remote.

When I say that ess-remote didn't work I mean it failed in the same way 
described originally (below).
> Thanks for the reports. It's really a very important contribution.
>     Vitalie
>   >>> Ross Boylan on Fri, 04 Apr 2014 13:58:46 -0700 wrote:
>   > On 4/4/2014 1:48 PM, Ross Boylan wrote:
>   >> I just updated ess from git (2737b5b98784961897503c29c139c735cb0ead24) and am
>   >> having problems getting the ess-remote command to complete.
>   >>
>   >> emacs 23.2.1, Debian 6.0.7.  I start emacs (non-gui) and start a shell within
>   >> it.  I launch R via a script that sets up an MPI session (openmpi) and give
>   >> the emacs command ess-remote.  I hit enter for R when prompted for the session
>   >> type.
>   >>
>   >> The terminal just sits there.  If I try to type in it there is no response.
>   >> If I hit ctl-g the line options(pager='cat') appears and I can type commands
>   >> into R.  After doing this a couple of times iESS appeared in the mode line (it
>   >> may have happened the first time).
>   >>
>   >> I just tried reproducing the problem, and this time everything just worked.
>   >> Ross Boylan
>   > And now it happened again.  One other thing: with the unsuccessful ess-remotes
>   > that status line shows
>   > Type C-h m for help on ESS Version 13.09-2
>   > The model line changed to iESS the first time I hit C-g.
>   > Ross
>   > ______________________________________________
>   > ESS-help at r-project.org mailing list
>   > https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list