[ESS] problems with ess-remote in git

Ross Boylan ross at biostat.ucsf.edu
Fri Apr 4 22:58:46 CEST 2014

On 4/4/2014 1:48 PM, Ross Boylan wrote:
> I just updated ess from git (2737b5b98784961897503c29c139c735cb0ead24) 
> and am having problems getting the ess-remote command to complete.
> emacs 23.2.1, Debian 6.0.7.  I start emacs (non-gui) and start a shell 
> within it.  I launch R via a script that sets up an MPI session 
> (openmpi) and give the emacs command ess-remote.  I hit enter for R 
> when prompted for the session type.
> The terminal just sits there.  If I try to type in it there is no 
> response.  If I hit ctl-g the line options(pager='cat') appears and I 
> can type commands into R.  After doing this a couple of times iESS 
> appeared in the mode line (it may have happened the first time).
> I just tried reproducing the problem, and this time everything just 
> worked.
> Ross Boylan
And now it happened again.  One other thing: with the unsuccessful 
ess-remotes that status line shows
Type C-h m for help on ESS Version 13.09-2

The model line changed to iESS the first time I hit C-g.


More information about the ESS-help mailing list