[ESS] ESS Hangs: Text is read-only

Mathieu Basille basille.web at ase-research.org
Wed Apr 2 16:38:36 CEST 2014

Le 04/01/2014 06:55 PM, Sparapani, Rodney a écrit :
> But, what is left click for you?  Do F1 k <left click>?

Rodney, I have the same thing as you (I have to admit I was initially 
puzzled by your question :D):

It is bound to <down-mouse-1>.

(mouse-drag-region START-EVENT)

Le 04/02/2014 03:31 AM, Vitalie Spinu a écrit :
> Same behavior on RET?

Yes: nothing on the Pdf, and the 'make-directory' message for Rnw/R.

> With pdfs ESS uses vignete R command. Go to the link and do M-: and eval
> this:
>      (format "vignette('%s', package='%s')\n"
>                         (get-text-property (point) 'vignette)
>                         (get-text-property (point) 'package))
> the resulting string is the literal command used.

I tried this for the package 'fortunes' (everybody should have it!). Here 
is what I have on the vignette buffer:


Pdf Rnw R	fortunes

And if eval the command you suggested, nothing happens. Here is the output 
(from the Messages buffer):

"vignette('R Fortunes: Collected Wisdom', package='fortunes')

If I try this command directly in the R buffer, I have a warning and the 
Pdf does not load:

 > vignette('R Fortunes: Collected Wisdom', package='fortunes')
Warning message:
vignette ‘R Fortunes: Collected Wisdom’ not found

If I do the following, however, it works, and the Pdf is properly loaded:

 > vignette('fortunes', package='fortunes')

My take on this (and this seems to be correct if I compare it to other R 
packages), ESS uses the full title and note the the (base) name of the 
vignette ("topic", from the help page of 'vignette'). For instance, with 


Pdf Rnw R	markdown-output
Pdf Rnw R	markdown-examples

 > vignette('HTML Output from Markdown Examples', package='markdown')
Warning message:
vignette ‘HTML Output from Markdown Examples’ not found
## And nothing happens
 > vignette('markdown-output', package='markdown')
## Works now, load the HTML version of the vignette in the browser

> For Rnw and R ESS just opens the link:
> Do M-x: (get-text-property (point) 'help-echo) and check if the
> resulting file exist. I expect your problems come from wrong filenames.

It consistently returns "[No match]" in the minibuffer, with no additional 

> If so, then please check .ess_vignetes() function and see what goes
> wrong.

I don't have .ess_vignetes or .ess_vignette or .ess_vignettes in my R 
session. Don't seem to be present in my ESS installation either:

grep -R ".ess_vignet" .

did not return anything...

Hope this helps...

> Thanks,
>    Vitalie

More information about the ESS-help mailing list