[ESS] Rterm

Richard M. Heiberger rmh at temple.edu
Sat Nov 2 00:29:51 CET 2013


The etiquette of this list is that you should stay on the list.  I am
putting this back
on the list.

I don't understand how that could be because the defun M-x
R-3.0.2-64bit is defined by the same
startup actions that define M-x R.
please send to the list your emacs version M-x version and ess version
M-x ess-version

Perhaps you overwrote M-x R?
Check in the *scratch* buffer by typing
(symbol-function 'R) C-j
also check
(symbol-function 'R-newest) C-j

Please try starting emacs without any local files.  From the MSDOS cmd prompt
emacs -Q
Then enter
(load-file "c:/path/to/ess/on/your/machine/lisp/ess-site.el")
Then try
M-x R

If that works, there is a problem with your site-start.el or your .emacs file

Since you are getting a complaint about Rterm not executable,
please confirm that both
c:/Program Files/R/R-3.0.2/bin/i386/Rterm.exe
c:/Program Files/R/R-3.0.2/bin/x64/Rterm.exe
are present and executable.

Please describe precisely (such that we can duplicate what you did) exactly
what you tried and the exact phrasing of what the system said.

Please report back to the list what finally worked.


On Fri, Nov 1, 2013 at 6:58 PM, Patrick Rioux <p.drioux at gmail.com> wrote:
> Hi,
> I downloaded R in the default location which is "c:/program files/". I tried
> various solutions but it seems the access to R is always denied... the only
> way to open R is to write "M-x R-3.0.2-64bit", but it is a little
> inconvenient...
> If you have any solutions please let me know,
> Thank you
> 2013/10/31 Richard M. Heiberger <rmh at temple.edu>
>> most likely you put R in a non-standard place.
>> ESS looks in "c:/program files/"
>> If you have R anywhere else you need to tell ESS before starting ESS.
>> Please see
>> C-h v ess-directory-containing-R
>> for the details.
>> On Thu, Oct 31, 2013 at 9:17 AM, Patrick Rioux <p.drioux at gmail.com> wrote:
>> > Hi,
>> >
>> > Whenever I try to open R from Emacs, it says :
>> > "apply: Searching for program: permission denied, Rterm"
>> >
>> > I have the new ESS with the latest Emacs version and R-3.0.2. Also, when
>> > I
>> > open Emacs, it says : "No version of R could be found on your system". I
>> > wonder if there is anything I could do to fix the problem.
>> >
>> > Please help me,
>> >
>> > --
>> > *Patrick Rioux*
>> >
>> >         [[alternative HTML version deleted]]
>> >
>> > ______________________________________________
>> > ESS-help at r-project.org mailing list
>> > https://stat.ethz.ch/mailman/listinfo/ess-help
> --
> Patrick Rioux

More information about the ESS-help mailing list