[ESS] ESS 13.05 release next week: beta testers welcome

Ross Boylan ross at biostat.ucsf.edu
Fri May 10 19:27:58 CEST 2013

On Thursday, May 09, 2013 01:05:51 PM Brian Diggs wrote:
> I've cloned a copy of the git repository into ~/.emacs.d/site-lisp so it
> is in the ESS directory there. I put
> (setq load-path
>        (append '("~/.emacs.d/site-lisp/")
>                load-path))
> ;; where the development git checkout resides
> (setq load-path
>        (append '("~/.emacs.d/site-lisp/ESS/")
>                load-path))
> at the top of my .emacs file. [I don't know if I need both of those or
> not; my emacs hacking skills are not that great.] However, I still seem
> to be getting the version of ess which comes with the distribution;
> ess-version gives
> ess-version : 12.09-2 [rev. 5395 (2013-01-10)]
> I don't want to replace ess that comes with the distribution (in
> c:/Program Files (x86)/GNU Emacs 24.2/site-lisp/ess/) because I want to
> easily revert back to a "good" version when I'm not testing.
> If it is useful, here is the value of load-path
I've found it challenging to ignore the "standard" ESS on both Windows and 
Linux.  I ended up moving the regular ESS directory out of the way so that it 
can't be found.

It tends to get loaded before your local emacs stuff is, so that it is hard to 
avoid it.

Another option is to start emacs telling it to ignore system initialization 
files.  That's fairly extreme.  I have also tried loading without system files, 
having my .emacs load the ESS I want, and then having my local .emacs do the 
standard system initialization commands.  Since the first version of the   
package loaded wins, that seemed to work.  But it made me a little nervous.

Also, notice you are appending the ESS directory you want to the path list, 
which means earlier versions will take precedence.  As I said, I don't think 
prepending it will help since ESS is already loaded by the time your local 
code kicks in.

> ("c:/Program Files (x86)/GNU Emacs 24.2/site-lisp/auctex" "c:/Program
> Files (x86)/GNU Emacs 24.2/site-lisp/ess/" "~/.emacs.d/site-lisp/ESS/"
> "~/.emacs.d/site-lisp/" "c:/Program Files (x86)/GNU Emacs
> 24.2/site-lisp" "c:/Program Files (x86)/GNU Emacs 24.2/site-lisp/ess"
> "c:/Program Files (x86)/GNU Emacs 24.2/site-lisp/org" "c:/Program Files
> (x86)/GNU Emacs 24.2/site-lisp/site-start.d" "C:/Program Files (x86)/GNU
> Emacs 24.2/../site-lisp" "C:/Program Files (x86)/GNU Emacs 24.2/lisp"
> "c:/Program Files (x86)/GNU Emacs 24.2/lisp/vc" "c:/Program Files
> (x86)/GNU Emacs 24.2/lisp/url" "c:/Program Files (x86)/GNU Emacs
> 24.2/lisp/textmodes" "c:/Program Files (x86)/GNU Emacs
> 24.2/lisp/progmodes" "c:/Program Files (x86)/GNU Emacs 24.2/lisp/play"
> "c:/Program Files (x86)/GNU Emacs 24.2/lisp/org" "c:/Program Files
> (x86)/GNU Emacs 24.2/lisp/nxml" "c:/Program Files (x86)/GNU Emacs
> 24.2/lisp/net" "c:/Program Files (x86)/GNU Emacs 24.2/lisp/mh-e"
> "c:/Program Files (x86)/GNU Emacs 24.2/lisp/mail" "c:/Program Files
> (x86)/GNU Emacs 24.2/lisp/language" "c:/Program Files (x86)/GNU Emacs
> 24.2/lisp/international" "c:/Program Files (x86)/GNU Emacs
> 24.2/lisp/gnus" "c:/Program Files (x86)/GNU Emacs 24.2/lisp/eshell"
> "c:/Program Files (x86)/GNU Emacs 24.2/lisp/erc" "c:/Program Files
> (x86)/GNU Emacs 24.2/lisp/emulation" "c:/Program Files (x86)/GNU Emacs
> 24.2/lisp/emacs-lisp" "c:/Program Files (x86)/GNU Emacs 24.2/lisp/cedet"
> "c:/Program Files (x86)/GNU Emacs 24.2/lisp/calendar" "c:/Program Files
> (x86)/GNU Emacs 24.2/lisp/calc" "c:/Program Files (x86)/GNU Emacs
> 24.2/lisp/obsolete" "C:/Program Files (x86)/GNU Emacs 24.2/leim")
> I don't know what is causing the "wrong" ess to be found. I tried
> eliminating everything in my .emacs file except those load-path
> adjustments, but that didn't help. What is the right way to do this?

More information about the ESS-help mailing list