[ESS] ESS with Julia built from source breaks plotting

Vitalie Spinu spinuvit at gmail.com
Sat Mar 30 10:13:00 CET 2013

Hi Gustavo, 

Please try from no-readline terminal, aka julia-release-basic. If it
work there then it is indeed an ESS problem, if not then you should
report it to julia-dev.

In the former case, could you please provide a self contained
reproducible example?


  >> Gustavo Lacerda <guse at optimizelife.com>
  >> on Fri, 29 Mar 2013 22:13:30 -0400 wrote:

 > hi,
 > I just built julia 0.2 from source, and have been using it with ESS.
 > Unfortunately, Winston (plotting package) doesn't work when I run
 > Julia from Emacs.  It *does* work when I run it from a regular
 > terminal.

 > This is my .emacs:
 > (setq inferior-julia-program-name
 > "~/projects/julia/usr/bin/julia-release-basic")
 > (add-to-list 'load-path "~/projects/julia/contrib/")

 > How would you go about ensuring that the Emacs/ESS environment is the
 > same as the terminal environment?

 > Gustavo

 > ______________________________________________
 > ESS-help at r-project.org mailing list
 > https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list