[ESS] did I just update my packages? [No--with work-around]

Ross Boylan ross at biostat.ucsf.edu
Thu Mar 28 01:48:57 CET 2013

It seems pretty clear the answer is no: nothing I did updated the packages.
I started the R GUI and ran update.packages; it did give me a message 
about each package. It seems to have mostly worked, although it did say
> package ‘colorspace’ successfully unpacked and MD5 sums checked
> Warning: unable to move temporary installation 
> ‘C:\Users\rdboylan\Documents\R\R-2.15.3\site-library\file748309221be\colorspace’ 
> to ‘C:\Users\rdboylan\Documents\R\R-2.15.3\site-library\colorspace’
I figured this might be from the fact that R was still running in ESS, 
although why colorspace would be the only package with the problem I 
don't know (because I did windows()?). So I shut the other R down and ran
> update.packages(checkBuilt=TRUE, ask=FALSE, oldPkgs="colorspace")
which produced no output at all.

At any rate, these last issues likely have nothing to do with ESS.


On 3/27/2013 5:14 PM, Ross Boylan wrote:
> I'm running on MS Windows 7 with R installed to a local directory (no 
> admin rights). ESS 12.09-1 under emacs 24.2.1.
> I just installed R 2.15.3 and copied the site-library directory from 
> 2.15.2. I'm not sure if this level of change requires an update, but 
> to be safe I did (from within ESS)
> update.packages(checkBuilt=TRUE, ask=FALSE)
> as suggested in the R Windows FAQ (however, I did not uninstall 2.15.2 
> first, though the FAQ suggests that).
> The bell rang and the terminal showed
> --- Please select a CRAN mirror for use in this session ---
> and hung. A combination of ctl-g's and ctl-c's got me out of it.
> This seems to be a well known problem on Windows.
> https://stat.ethz.ch/pipermail/ess-help/2005-December/003085.html 
> indicated that issuing the command windows() before the update would 
> solve the problem. windows() did result in a graphics device window 
> coming up. update.packages(checkBuilt=TRUE, ask=FALSE) ran instantly, 
> but it gave no messages indicating it was doing anything. I also tried
>> > getOption("repos")[2]
>> CRANextra
>> "http://www.stats.ox.ac.uk/pub/RWin"
>> > update.packages(checkBuilt=TRUE, ask=FALSE, 
>> repos=getOption("repos")[2])
> which also ran instantly and silently.
> Does anyone know if this means my packages are up to date or not? 
> Should update.packages() be chattier (I seem to recall it listing each 
> package and giving its status when I've run it before)?
> Thanks.
> Ross Boylan

More information about the ESS-help mailing list